aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gnomeiconedit
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-08 18:41:30 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-08 18:41:30 +0800
commit27b58e05583dbd0dbed960cf162e599ebc0f227b (patch)
tree08d4d418aed90a1f7e8eb25819d284dce8d35a8b /graphics/gnomeiconedit
parente5f65fe9c160b78b54514fe1bebfa37c1259f7c8 (diff)
downloadfreebsd-ports-gnome-27b58e05583dbd0dbed960cf162e599ebc0f227b.tar.gz
freebsd-ports-gnome-27b58e05583dbd0dbed960cf162e599ebc0f227b.tar.zst
freebsd-ports-gnome-27b58e05583dbd0dbed960cf162e599ebc0f227b.zip
PERL -> REINPLACE_CMD
PR: 39938 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'graphics/gnomeiconedit')
-rw-r--r--graphics/gnomeiconedit/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/gnomeiconedit/Makefile b/graphics/gnomeiconedit/Makefile
index 9b23396de18f..9dbf216431af 100644
--- a/graphics/gnomeiconedit/Makefile
+++ b/graphics/gnomeiconedit/Makefile
@@ -13,6 +13,7 @@ DISTNAME= gnome-iconedit-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_GNOME= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -24,10 +25,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\$$(datadir)/gnome/|\$$(datadir)/|g ; \
+ s|\$$(datadir)/locale|\$$(prefix)/share/locale|g'
.include <bsd.port.mk>