aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/goom
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-06-22 20:37:03 +0800
committerkwm <kwm@FreeBSD.org>2005-06-22 20:37:03 +0800
commite511ef714eac002cfa5821c835935206b19bc9c4 (patch)
treefe6834b5ad293703c0b7c384f47fafdcf6f34117 /graphics/goom
parentcbd456c0b4d7caf42af5a353d0bf4453009776d8 (diff)
downloadfreebsd-ports-gnome-e511ef714eac002cfa5821c835935206b19bc9c4.tar.gz
freebsd-ports-gnome-e511ef714eac002cfa5821c835935206b19bc9c4.tar.zst
freebsd-ports-gnome-e511ef714eac002cfa5821c835935206b19bc9c4.zip
Add goom. Goom is a visual effects library with optional xmms plugin.
Diffstat (limited to 'graphics/goom')
-rw-r--r--graphics/goom/Makefile41
-rw-r--r--graphics/goom/distinfo2
-rw-r--r--graphics/goom/pkg-descr3
-rw-r--r--graphics/goom/pkg-plist19
4 files changed, 65 insertions, 0 deletions
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
new file mode 100644
index 000000000000..02ca854cf5b9
--- /dev/null
+++ b/graphics/goom/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: goom
+# Date created: 12 February 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goom
+PORTVERSION= 2k4.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|-|}-src
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Visual effects library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S|.|-|}
+USE_GNOME= gnomehack gnometarget
+GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-sdltest
+INSTALLS_SHLIB= yes
+
+.if exists(${X11R6}/bin/xmms) || defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+PLIST_SUB+= XMMS=""
+.else
+PLIST_SUB+= XMMS="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITH_XMMS)
+ @${ECHO} ""
+ @${ECHO} "Define WITH_XMMS to build goom xmms visualization plugin"
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/goom/distinfo b/graphics/goom/distinfo
new file mode 100644
index 000000000000..f8227d5240db
--- /dev/null
+++ b/graphics/goom/distinfo
@@ -0,0 +1,2 @@
+MD5 (goom-2k4-0-src.tar.gz) = 8100dd07e0c6784fdf079eeaa53a5c7f
+SIZE (goom-2k4-0-src.tar.gz) = 757058
diff --git a/graphics/goom/pkg-descr b/graphics/goom/pkg-descr
new file mode 100644
index 000000000000..e673fff45844
--- /dev/null
+++ b/graphics/goom/pkg-descr
@@ -0,0 +1,3 @@
+Goom2 visual effects library. With optional xmms plugin.
+
+WWW: http://sourceforge.net/projects/goom
diff --git a/graphics/goom/pkg-plist b/graphics/goom/pkg-plist
new file mode 100644
index 000000000000..ed1170abe655
--- /dev/null
+++ b/graphics/goom/pkg-plist
@@ -0,0 +1,19 @@
+include/goom/goom.h
+include/goom/goom_config.h
+include/goom/goom_config_param.h
+include/goom/goom_filters.h
+include/goom/goom_graphic.h
+include/goom/goom_plugin_info.h
+include/goom/goom_tools.h
+include/goom/goom_typedefs.h
+include/goom/goom_visual_fx.h
+include/goom/goomsl.h
+include/goom/goomsl_hash.h
+include/goom/goomsl_heap.h
+lib/libgoom2.a
+lib/libgoom2.so
+lib/libgoom2.so.0
+libdata/pkgconfig/libgoom2.pc
+%%XMMS%%@cwd %%X11BASE%%
+%%XMMS%%lib/xmms/Visualization/libxmmsgoom2.so
+@dirrm include/goom