aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gphoto2
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-08 22:32:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-08 22:32:46 +0800
commitc30c0fbf24f143aae425fa343da9132b11e42e27 (patch)
tree901c5a138aeb88ac1a3419cac9d5a56207ecde15 /graphics/gphoto2
parentc735239a00d50481555397d845471e6ec1c73e8c (diff)
downloadfreebsd-ports-gnome-c30c0fbf24f143aae425fa343da9132b11e42e27.tar.gz
freebsd-ports-gnome-c30c0fbf24f143aae425fa343da9132b11e42e27.tar.zst
freebsd-ports-gnome-c30c0fbf24f143aae425fa343da9132b11e42e27.zip
- Convert USE_BZIP2 to USES
- Fix NLS support
Diffstat (limited to 'graphics/gphoto2')
-rw-r--r--graphics/gphoto2/Makefile10
-rw-r--r--graphics/gphoto2/files/patch-configure17
2 files changed, 22 insertions, 5 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 390433c41676..36dd0898e677 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt \
libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
-USE_BZIP2= yes
-USES= gmake pkgconfig
+USES= tar:bzip2 gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= POPT_CFLAGS="$$(pkg-config --cflags popt)" \
POPT_LIBS="$$(pkg-config --libs popt)"
@@ -30,14 +29,15 @@ AALIB_LIB_DEPENDS= libaa.so:${PORTSDIR}/graphics/aalib
AALIB_CONFIGURE_WITH= aalib
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
+NLS_CONFIGURE_ENV= LIBS="-lintl"
READLINE_USES= readline
READLINE_CONFIGURE_WITH= readline
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lpthread|-pthread|' \
+ 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/configure
post-install:
diff --git a/graphics/gphoto2/files/patch-configure b/graphics/gphoto2/files/patch-configure
new file mode 100644
index 000000000000..db1f5d2445d8
--- /dev/null
+++ b/graphics/gphoto2/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig 2014-05-08 17:21:32.000000000 +0400
++++ configure 2014-05-08 17:23:08.000000000 +0400
+@@ -12988,13 +12988,11 @@
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <libintl.h>
+-extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ int
+ main ()
+ {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
++return (int) gettext ("");
+ ;
+ return 0;
+ }