aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gpsmanshp/Makefile
diff options
context:
space:
mode:
authorjhay <jhay@FreeBSD.org>2004-07-19 03:16:03 +0800
committerjhay <jhay@FreeBSD.org>2004-07-19 03:16:03 +0800
commit1316c7895c9931f2bade0a72ea0a0b455339a778 (patch)
tree35e5402062c5798805a38c47240cbc7dbdf48567 /graphics/gpsmanshp/Makefile
parent94376a10d2f417af1cb89907fd7d71671d213751 (diff)
downloadfreebsd-ports-gnome-1316c7895c9931f2bade0a72ea0a0b455339a778.tar.gz
freebsd-ports-gnome-1316c7895c9931f2bade0a72ea0a0b455339a778.tar.zst
freebsd-ports-gnome-1316c7895c9931f2bade0a72ea0a0b455339a778.zip
Initial import of gpsmanshp 1.2
Provides Tcl/Tk shapelib file support for gpsman.
Diffstat (limited to 'graphics/gpsmanshp/Makefile')
-rw-r--r--graphics/gpsmanshp/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/gpsmanshp/Makefile b/graphics/gpsmanshp/Makefile
new file mode 100644
index 000000000000..4fd8266ba652
--- /dev/null
+++ b/graphics/gpsmanshp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gpsmanshp
+# Date created: 7 July 2004
+# Whom: John Hay
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpsmanshp
+PORTVERSION= 1.2
+CATEGORIES= graphics tcl84
+MASTER_SITES= http://www.ncc.up.pt/gpsmanshp/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jhay@FreeBSD.org
+COMMENT= Shapelib support for gpsman
+
+RUN_DEPENDS= gpsman:${PORTSDIR}/astro/gpsman
+LIB_DEPENDS= shp.1:${PORTSDIR}/devel/shapelib
+
+PLIST_SUB= TCLVERSION=8.4 PORTVERSION=${PORTVERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>