aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/graphene
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-04-18 20:58:16 +0800
committerkwm <kwm@FreeBSD.org>2017-04-18 20:58:16 +0800
commit170bc9be314f7b3a450c6b842efb9a8857b79f4f (patch)
treeb9e47edd1671ce598fd1df7f9c2275528b2e7cc8 /graphics/graphene
parent3fed48d7b7791f357a79cc3b941ea5e115466707 (diff)
downloadfreebsd-ports-gnome-170bc9be314f7b3a450c6b842efb9a8857b79f4f.tar.gz
freebsd-ports-gnome-170bc9be314f7b3a450c6b842efb9a8857b79f4f.tar.zst
freebsd-ports-gnome-170bc9be314f7b3a450c6b842efb9a8857b79f4f.zip
Graphene contains optimizations for speeding up vector operations, those
optimizations are optional, and used only if both Graphene was compiled with support for them and if the system you're running on has them. Currently, Graphene supports the following platform-specific fast paths: Streaming SIMD Extensions (SSE) 2 ARM NEON GCC vector extensions In the remote case in which none of these optimizations are available, Graphene will fall back to a naïve scalar implementation http://ebassi.github.io/graphene/
Diffstat (limited to 'graphics/graphene')
-rw-r--r--graphics/graphene/Makefile38
-rw-r--r--graphics/graphene/distinfo3
-rw-r--r--graphics/graphene/pkg-descr16
-rw-r--r--graphics/graphene/pkg-plist75
4 files changed, 132 insertions, 0 deletions
diff --git a/graphics/graphene/Makefile b/graphics/graphene/Makefile
new file mode 100644
index 000000000000..ab59b3b9b2d3
--- /dev/null
+++ b/graphics/graphene/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= graphene
+PORTVERSION= 1.6.0
+CATEGORIES= graphics devel
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Optimizations for speeding up vector operations
+
+LICENSE= MIT
+
+USES= gnome meson pkgconfig python:3 shebangfix tar:xz
+USE_GNOME= glib20 py3gobject3
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= GTKDOC #INTROSPECTION
+#OPTIONS_DEFAULT=INTROSPECTION
+
+SHEBANG_FILES= src/identfilter.py
+
+USE_GNOME+= introspection:build
+#INTROSPECTION_DESC= Build Gobject Introspection
+#INTROSPECTION_USE= gnome=introspection:build
+#INTROSPECTION_MESON_OFF= -Denable-introspection=false
+
+GTKDOC_MESON_TRUE= enable-gtk-doc
+GTKDOC_DESC= Build documentation
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|=python |=${PYTHON_VERSION} |g' \
+ ${WRKSRC}/src/meson.build
+
+# We don't want install tests
+post-install:
+ @${RM} -rf ${STAGEDIR}${PREFIX}/libexec/installed-tests
+
+.include <bsd.port.mk>
diff --git a/graphics/graphene/distinfo b/graphics/graphene/distinfo
new file mode 100644
index 000000000000..5cf73661de11
--- /dev/null
+++ b/graphics/graphene/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491756916
+SHA256 (graphene-1.6.0.tar.xz) = c3a9910f8dd298c1459d1f3c699ddf2e7440f9e561bfcbef59ae784400e27b5d
+SIZE (graphene-1.6.0.tar.xz) = 421228
diff --git a/graphics/graphene/pkg-descr b/graphics/graphene/pkg-descr
new file mode 100644
index 000000000000..5e96b569a49b
--- /dev/null
+++ b/graphics/graphene/pkg-descr
@@ -0,0 +1,16 @@
+Graphene contains optimizations for speeding up vector operations, those
+optimizations are optional, and used only if both Graphene was compiled
+with support for them and if the system you're running on has them.
+Currently, Graphene supports the following platform-specific fast paths:
+
+Streaming SIMD Extensions (SSE) 2
+ARM NEON
+GCC vector extensions
+In the remote case in which none of these optimizations are available,
+Graphene will fall back to a naïve scalar implementation
+
+Graphene can, optionally, provide types for integrating with GObject
+properties and signals, as well as introspection information for its
+use with other languages through introspection-based bindings.
+
+WWW: http://ebassi.github.io/graphene/
diff --git a/graphics/graphene/pkg-plist b/graphics/graphene/pkg-plist
new file mode 100644
index 000000000000..278f4893101e
--- /dev/null
+++ b/graphics/graphene/pkg-plist
@@ -0,0 +1,75 @@
+include/graphene-1.0/graphene-box.h
+include/graphene-1.0/graphene-euler.h
+include/graphene-1.0/graphene-frustum.h
+include/graphene-1.0/graphene-gobject.h
+include/graphene-1.0/graphene-macros.h
+include/graphene-1.0/graphene-matrix.h
+include/graphene-1.0/graphene-plane.h
+include/graphene-1.0/graphene-point.h
+include/graphene-1.0/graphene-point3d.h
+include/graphene-1.0/graphene-quad.h
+include/graphene-1.0/graphene-quaternion.h
+include/graphene-1.0/graphene-ray.h
+include/graphene-1.0/graphene-rect.h
+include/graphene-1.0/graphene-simd4f.h
+include/graphene-1.0/graphene-simd4x4f.h
+include/graphene-1.0/graphene-size.h
+include/graphene-1.0/graphene-sphere.h
+include/graphene-1.0/graphene-triangle.h
+include/graphene-1.0/graphene-types.h
+include/graphene-1.0/graphene-vec2.h
+include/graphene-1.0/graphene-vec3.h
+include/graphene-1.0/graphene-vec4.h
+include/graphene-1.0/graphene-version-macros.h
+include/graphene-1.0/graphene-version.h
+include/graphene-1.0/graphene.h
+lib/girepository-1.0/Graphene-1.0.typelib
+lib/graphene-1.0/include/graphene-config.h
+lib/libgraphene-1.0.so
+lib/libgraphene-1.0.so.0
+lib/libgraphene-1.0.so.0.600.0
+lib/pkgconfig/graphene-1.0.pc
+lib/pkgconfig/graphene-gobject-1.0.pc
+share/gir-1.0/Graphene-1.0.gir
+%%GTKDOC%%share/gtk-doc/html/graphene/annotation-glossary.html
+%%GTKDOC%%share/gtk-doc/html/graphene/api-index.html
+%%GTKDOC%%share/gtk-doc/html/graphene/ch01.html
+%%GTKDOC%%share/gtk-doc/html/graphene/deprecated-api-index.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Box.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Euler.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Frustum.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-GObject-integration.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Matrix.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Plane.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Point.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Point3D.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Quad.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Quaternion.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Ray.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Rectangle.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-SIMD-matrix.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-SIMD-vector.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Size.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Sphere.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Triangle.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Vectors.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene-Versioning-information.html
+%%GTKDOC%%share/gtk-doc/html/graphene/graphene.devhelp2
+%%GTKDOC%%share/gtk-doc/html/graphene/home.png
+%%GTKDOC%%share/gtk-doc/html/graphene/index.html
+%%GTKDOC%%share/gtk-doc/html/graphene/ix03.html
+%%GTKDOC%%share/gtk-doc/html/graphene/ix04.html
+%%GTKDOC%%share/gtk-doc/html/graphene/ix05.html
+%%GTKDOC%%share/gtk-doc/html/graphene/ix06.html
+%%GTKDOC%%share/gtk-doc/html/graphene/left-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/graphene/left.png
+%%GTKDOC%%share/gtk-doc/html/graphene/object-tree.html
+%%GTKDOC%%share/gtk-doc/html/graphene/rectangle-intersection.png
+%%GTKDOC%%share/gtk-doc/html/graphene/rectangle-union.png
+%%GTKDOC%%share/gtk-doc/html/graphene/rectangle.png
+%%GTKDOC%%share/gtk-doc/html/graphene/right-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/graphene/right.png
+%%GTKDOC%%share/gtk-doc/html/graphene/style.css
+%%GTKDOC%%share/gtk-doc/html/graphene/triangle-barycentric.png
+%%GTKDOC%%share/gtk-doc/html/graphene/up-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/graphene/up.png