aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gscan2pdf/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-09-04 20:07:28 +0800
committersat <sat@FreeBSD.org>2006-09-04 20:07:28 +0800
commit2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9 (patch)
tree3e31f9762ca14101a29c727a49db98bd45357de8 /graphics/gscan2pdf/Makefile
parentd37ad52865f1d948e101bef07468c53ceaf0e96d (diff)
downloadfreebsd-ports-gnome-2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9.tar.gz
freebsd-ports-gnome-2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9.tar.zst
freebsd-ports-gnome-2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9.zip
Add port graphics/gscan2pdf:
A GUI to ease the process of producing PDFs from scanned documents WWW: http://sourceforge.net/projects/gscan2pdf Author: Jeffrey Ratcliffe <jeffreyratcliffe@yahoo.co.uk>
Diffstat (limited to 'graphics/gscan2pdf/Makefile')
-rw-r--r--graphics/gscan2pdf/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
new file mode 100644
index 000000000000..c644322c2945
--- /dev/null
+++ b/graphics/gscan2pdf/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gscan2pdf
+# Date created: 4 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gscan2pdf
+PORTVERSION= 0.6.1
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Produce PDF from scanned documents
+
+RUN_DEPENDS= tiff2pdf:${PORTSDIR}/graphics/tiff \
+ ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -Ee 's!tiff2pdf (.*) \$$options!tiff2pdf \$$options \1!' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>