aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gstreamer-plugins-gl/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-09-07 14:52:39 +0800
committerkwm <kwm@FreeBSD.org>2010-09-07 14:52:39 +0800
commitb319dafa0d4b0fe23c59f7ac5eb2df00bf7b2181 (patch)
tree9b914dbf26db1c20ad18b1bffb30aa584b712642 /graphics/gstreamer-plugins-gl/Makefile
parentc0905cbd9504175248844bac9603c786b59f44bd (diff)
downloadfreebsd-ports-gnome-b319dafa0d4b0fe23c59f7ac5eb2df00bf7b2181.tar.gz
freebsd-ports-gnome-b319dafa0d4b0fe23c59f7ac5eb2df00bf7b2181.tar.zst
freebsd-ports-gnome-b319dafa0d4b0fe23c59f7ac5eb2df00bf7b2181.zip
Add gstreamer-plugins-gl 0.10.2.
This Gstreamer plugin suppies: * Integration with stanard GStreamer video buffers * Various OpenGL effects and filters * Direct GL output via glimagesink
Diffstat (limited to 'graphics/gstreamer-plugins-gl/Makefile')
-rw-r--r--graphics/gstreamer-plugins-gl/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/gstreamer-plugins-gl/Makefile b/graphics/gstreamer-plugins-gl/Makefile
new file mode 100644
index 000000000000..27012b7e551e
--- /dev/null
+++ b/graphics/gstreamer-plugins-gl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gstreamer-plugins-gl
+# Date created: 6 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstreamer-plugins-gl
+PORTVERSION= 0.10.2
+CATEGORIES= multimedia
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-gl/
+DISTNAME= ${PORTNAME:S/gstreamer/gst/}-${PORTVERSION}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= GStreamer OpenGL video plugin
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack
+USE_GSTREAMER= yes
+USE_XORG= ice x11
+USE_GL= gl glu glew
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS=--disable-examples
+
+PLIST_SUB= VERSION="0.10"
+
+.include <bsd.port.mk>