aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gtkam
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-14 06:27:40 +0800
committermarcus <marcus@FreeBSD.org>2003-04-14 06:27:40 +0800
commit24f35055ad0c3e41f36d293da009162a658836ad (patch)
tree27eb787538b19746ec311d5658e66f2045136866 /graphics/gtkam
parente9717422d572226de6ce1090595456adbf73c39f (diff)
downloadfreebsd-ports-gnome-24f35055ad0c3e41f36d293da009162a658836ad.tar.gz
freebsd-ports-gnome-24f35055ad0c3e41f36d293da009162a658836ad.tar.zst
freebsd-ports-gnome-24f35055ad0c3e41f36d293da009162a658836ad.zip
* Fix gimp plugin installation [1]
* Convert to new GNOME infrastructure PR: 48579 [1] Submitted by: Alexander Nedotsukov <bland@mail.ru>
Diffstat (limited to 'graphics/gtkam')
-rw-r--r--graphics/gtkam/Makefile5
-rw-r--r--graphics/gtkam/files/patch-src_Makefile.in11
2 files changed, 13 insertions, 3 deletions
diff --git a/graphics/gtkam/Makefile b/graphics/gtkam/Makefile
index 41591d58be7e..7d0c206fa63f 100644
--- a/graphics/gtkam/Makefile
+++ b/graphics/gtkam/Makefile
@@ -15,14 +15,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Download and view files from various digital cameras
LIB_DEPENDS= exif-gtk.4:${PORTSDIR}/graphics/libexif-gtk \
- gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
- bonoboui-2.0:${PORTSDIR}/x11-toolkits/libbonoboui
+ gphoto2.2:${PORTSDIR}/graphics/libgphoto2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= libbonoboui
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-gnome
diff --git a/graphics/gtkam/files/patch-src_Makefile.in b/graphics/gtkam/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..dbbc39c5c682
--- /dev/null
+++ b/graphics/gtkam/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat Feb 22 17:57:10 2003
++++ src/Makefile.in Sat Feb 22 17:57:28 2003
+@@ -169,7 +169,7 @@
+ $(GNOME_LIBS)
+
+
+-@HAVE_GIMP_TRUE@gtkam_gimp_libexecdir = $(libdir)/gimp/1.3/plug-ins
++@HAVE_GIMP_TRUE@gtkam_gimp_libexecdir = $(libexecdir)/gimp/1.3/plug-ins
+ @HAVE_GIMP_TRUE@gtkam_gimp_libexec_PROGRAMS = gtkam-gimp
+ @HAVE_GIMP_TRUE@gtkam_gimp_SOURCES = gtkam-gimp.c
+ @HAVE_GIMP_TRUE@gtkam_gimp_LDADD = \