aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gts
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-09-27 23:20:06 +0800
committerkrion <krion@FreeBSD.org>2003-09-27 23:20:06 +0800
commitc01dd5f09302667b14189184eb1c53fb4c882d75 (patch)
tree501b4cc781362e25cef1819a48510d3033b68fe8 /graphics/gts
parent11687b1e2619f563ef3a0fde217b07bcab1981a9 (diff)
downloadfreebsd-ports-gnome-c01dd5f09302667b14189184eb1c53fb4c882d75.tar.gz
freebsd-ports-gnome-c01dd5f09302667b14189184eb1c53fb4c882d75.tar.zst
freebsd-ports-gnome-c01dd5f09302667b14189184eb1c53fb4c882d75.zip
- Fix build on non-i386 platform
PR: 57285 Submitted by: Ports Fury
Diffstat (limited to 'graphics/gts')
-rw-r--r--graphics/gts/Makefile3
-rw-r--r--graphics/gts/files/patch-src::rounding.h16
2 files changed, 16 insertions, 3 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index dc9eaf0b1186..1045ed78a3d7 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -26,9 +26,6 @@ INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-# Supports only i386 FP operation
-ONLY_FOR_ARCHS= i386
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-release \$$(LT_RELEASE)||g'
diff --git a/graphics/gts/files/patch-src::rounding.h b/graphics/gts/files/patch-src::rounding.h
new file mode 100644
index 000000000000..666d1c1354a5
--- /dev/null
+++ b/graphics/gts/files/patch-src::rounding.h
@@ -0,0 +1,16 @@
+--- src/rounding.h.orig Mon Jun 17 12:05:45 2002
++++ src/rounding.h Wed Sep 24 12:57:41 2003
+@@ -28,11 +28,11 @@
+ _FPU_SETCW(fpu_round_double); }
+ # define FPU_RESTORE {_FPU_SETCW(fpu_init);}
+ #else /* not HAVE_FPU_CONTROL_H */
+-# ifdef __FreeBSD__
++# ifdef HAVE_FROATINGPOINT_H
+ # include <floatingpoint.h>
+ # define FPU_ROUND_DOUBLE (fpsetprec(FP_PD))
+ # define FPU_RESTORE (fpsetprec(FP_PE))
+-# else /* not __FreeBSD__ */
++# else /* not HAVE_FROATINGPOINT_H */
+ # ifdef WIN32
+ # ifdef _MSC_VER
+ # include <float.h>