aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/hpscan
diff options
context:
space:
mode:
authornate <nate@FreeBSD.org>1996-01-13 04:58:39 +0800
committernate <nate@FreeBSD.org>1996-01-13 04:58:39 +0800
commit60951af0bee7efc722265fe1a055a9f804e60ca9 (patch)
treee3b4a0215cf1de6f20a50f5afc63381210aca2b2 /graphics/hpscan
parentc5a091d69501e938a8958d97399c46e41531ad08 (diff)
downloadfreebsd-ports-gnome-60951af0bee7efc722265fe1a055a9f804e60ca9.tar.gz
freebsd-ports-gnome-60951af0bee7efc722265fe1a055a9f804e60ca9.tar.zst
freebsd-ports-gnome-60951af0bee7efc722265fe1a055a9f804e60ca9.zip
HP ScanJet user-level scanner driver written by Richard Tobin.
This code is known to work with the HP3C, but was written for the HP IIcx, so it appears to be generically applicable to newer HP scanners.
Diffstat (limited to 'graphics/hpscan')
-rw-r--r--graphics/hpscan/Makefile21
-rw-r--r--graphics/hpscan/distinfo1
-rw-r--r--graphics/hpscan/files/patch-aa33
-rw-r--r--graphics/hpscan/pkg-comment1
-rw-r--r--graphics/hpscan/pkg-descr64
-rw-r--r--graphics/hpscan/pkg-plist2
6 files changed, 122 insertions, 0 deletions
diff --git a/graphics/hpscan/Makefile b/graphics/hpscan/Makefile
new file mode 100644
index 000000000000..4ee13702f15e
--- /dev/null
+++ b/graphics/hpscan/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hpscan
+# Version required: <own lineage>
+# Date created: 12 January 1996
+# Whom: nate
+#
+# $Id: Makefile,v 1.6 1995/11/27 04:05:37 asami Exp $
+#
+
+DISTNAME= scanner
+PKGNAME= hpscan
+CATEGORIES+= graphics
+MASTER_SITES= ftp://freefall.cdrom.com/pub/FreeBSD/LOCAL_PORTS/ \
+ ftp://macbeth.cogsci.ed.ac.uk/pub/
+
+NO_WRKSUBDIR= true
+USE_X11= true
+NO_INSTALL_MANPAGES= true
+
+MAINTAINER= nate@FreeBSD.org
+
+.include <bsd.port.mk>
diff --git a/graphics/hpscan/distinfo b/graphics/hpscan/distinfo
new file mode 100644
index 000000000000..fdddd1208e9a
--- /dev/null
+++ b/graphics/hpscan/distinfo
@@ -0,0 +1 @@
+MD5 (scanner.tar.gz) = 8d881074dbe5502b88ae209a96e62549
diff --git a/graphics/hpscan/files/patch-aa b/graphics/hpscan/files/patch-aa
new file mode 100644
index 000000000000..35ccb3f9e0fb
--- /dev/null
+++ b/graphics/hpscan/files/patch-aa
@@ -0,0 +1,33 @@
+*** Makefile.orig Fri Jun 3 05:52:36 1994
+--- Makefile Fri Jan 12 10:31:44 1996
+***************
+*** 1,13 ****
+! INCLUDES= -I/usr/X386/include
+! LIBS= -L/usr/X386/lib -lXaw -lXt -lXmu -lX11 -lm
+ OPT= -g
+ CFLAGS= $(OPT) $(INCLUDES)
+! CC= gcc
+
+ OBJS= main.o scsi.o scanner.o scl.o gui.o colour.o Plain.o
+
+! scan: $(OBJS)
+ $(CC) -o scanner $(OBJS) $(LIBS)
+
+! tarfile:
+! tar zcvf macbeth:/graphics/software/ftp/pub/scanner.tar.gz *.[ch] Makefile README TODO
+--- 1,15 ----
+! INCLUDES= -I/usr/X11R6/include -I/sys
+! LIBS= -L/usr/X11R6/lib -lXaw -lXt -lXmu -lX11 -lm
+ OPT= -g
+ CFLAGS= $(OPT) $(INCLUDES)
+! CC= cc
+
+ OBJS= main.o scsi.o scanner.o scl.o gui.o colour.o Plain.o
+
+! all: scanner
+!
+! scanner: $(OBJS)
+ $(CC) -o scanner $(OBJS) $(LIBS)
+
+! install:
+! install -c -s -m 555 -o bin -g bin scanner ${X11BASE}/bin
diff --git a/graphics/hpscan/pkg-comment b/graphics/hpscan/pkg-comment
new file mode 100644
index 000000000000..84bb34ba3131
--- /dev/null
+++ b/graphics/hpscan/pkg-comment
@@ -0,0 +1 @@
+HP scanner driver. (* See description for further installation instructions)
diff --git a/graphics/hpscan/pkg-descr b/graphics/hpscan/pkg-descr
new file mode 100644
index 000000000000..7d30f29bff92
--- /dev/null
+++ b/graphics/hpscan/pkg-descr
@@ -0,0 +1,64 @@
+This is a HP SCSI scanner driver which uses the FreeBSD 'pt' (Processor
+Type) driver. It has been tested on the HP ScanJet 3C, and was written
+for the HP ScanJet IIcx, so I suspect it will work with all newer HP
+scanners without modifications.
+
+To install the driver you must add a line to your kernel config file
+like the following:
+# HP Scanner
+device pt0 at scbus?
+
+Re-configure, build, and install the new kernel. On bootup you should
+seem something similar to this which shows your scanner is attached:
+(ncr0:5:0): "HP C2520A 3503" type 3 fixed SCSI 2
+pt0(ncr0:5:0): Processor
+
+Next, you'll want to make a link from /dev/pt0 to /dev/scanner for the
+driver software.
+
+# cd /dev
+# ln -s pto0 scanner
+
+At this point, you should be able to run the scanner program and see
+results.
+
+- Nate
+
+
+Original README follows:
+---------------------------
+This software is copyright Richard Tobin 1994. It may be freely
+redistributed provided the copyright notices are not removed.
+
+You can ftp this code from macbeth.cogsci.ed.ac.uk.
+
+This is (a very early version of) a SCSI driver for the HP ScanJet range
+of scanners and a corresponding graphical user interface.
+
+The HP scanners (or at least some of them) are SCSI devices, but do
+not implement the SCSI scanner interface. Instead they act as SCSI
+processor devices. They use the SCSI send and receive commands to
+transfer (hard as it is to believe) escape sequences.
+
+The file scsi.c implements the SCSI send and receive commands in user
+mode, using the *BSD "uk" (unknown device) driver. The uk driver is
+somewhat flaky, rarely returning errors even if the device is switched
+off. Error detection is therefore likely to be minimal.
+
+The file scanner.c provides a thin layer on top of scsi.c, and might
+decode error returns if there were any.
+
+The file scl.c implements many of the HP SCL (Scanner Control
+Language) commands. This involves generating and parsing lots of
+escape sequences.
+
+The file gui.c provides a simple X interface to the scanner. It
+allows you to preview the whole scan area, zoom in on the bit you're
+interested in, and scan it to a file. So far it can only scan 24-bit
+colour, preview on a colour display, and produce ppm files.
+
+All of this has been hacked up in a hurry, so it's pretty minimal. It
+has been tried only under FreeBSD 1.1 with a ScanJet IIcx connected to
+an Adaptec 1542CF. I don't have much time to spend on it, so don't
+expect rapid improvements. Please send bug-reports and improvements
+to R.Tobin@ed.ac.uk.
diff --git a/graphics/hpscan/pkg-plist b/graphics/hpscan/pkg-plist
new file mode 100644
index 000000000000..72bb5a4d1cea
--- /dev/null
+++ b/graphics/hpscan/pkg-plist
@@ -0,0 +1,2 @@
+@cwd /usr/X11R6
+bin/scanner