aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/hugin
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2010-01-24 00:32:49 +0800
committervd <vd@FreeBSD.org>2010-01-24 00:32:49 +0800
commit2ef20c01360070eeffd37a6a02ceba4c8001fb37 (patch)
treedd95b2497b2e8c9321bfc315a9fbd186b7243dfc /graphics/hugin
parent7d065a35d1308189378f4cc5443a16eee22bbe58 (diff)
downloadfreebsd-ports-gnome-2ef20c01360070eeffd37a6a02ceba4c8001fb37.tar.gz
freebsd-ports-gnome-2ef20c01360070eeffd37a6a02ceba4c8001fb37.tar.zst
freebsd-ports-gnome-2ef20c01360070eeffd37a6a02ceba4c8001fb37.zip
graphics/hugin: Use GCC 4.4 or higher
The compilation fails on 6.x with GCC 3.4: ... [ 11%] Building CXX object src/hugin_base/CMakeFiles/huginbase.dir/algorithms/nona/NonaFileStitcher.cpp.o cd /work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base && /usr/bin/c++ -Dhuginbase_EXPORTS -O2 -fno-strict-aliasing -pipe -O2 -g -fPIC -I/work/a/ports/graphics/hugin/work/hugin-2009.4.0/src -I/work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base -I/work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/foreign -I/work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/foreign/vigra -I/work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/celeste -I/usr/local/include -I/usr/local/include/OpenEXR -o CMakeFiles/huginbase.dir/algorithms/nona/NonaFileStitcher.cpp.o -c /work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base/algorithms/nona/NonaFileStitcher.cpp In file included from /usr/local/include/boost/thread/future.hpp:12, from /usr/local/include/boost/thread.hpp:24, from /work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base/vigra_ext/MultiThreadOperations.h:30, from /work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base/vigra_ext/ImageTransforms.h:42, from /work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base/nona/Stitcher.h:49, from /work/a/ports/graphics/hugin/work/hugin-2009.4.0/src/hugin_base/algorithms/nona/NonaFileStitcher.cpp:33: /usr/local/include/boost/exception_ptr.hpp:43: error: looser throw specifier for `virtual boost::exception_ptr::~exception_ptr()' /usr/local/include/boost/exception/detail/exception_ptr_base.hpp:27: error: overriding `virtual boost::exception_detail::exception_ptr_base::~exception_ptr_base() throw ()' *** Error code 1 ... Reported by: pav
Diffstat (limited to 'graphics/hugin')
-rw-r--r--graphics/hugin/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 0ff4769c62af..bfb3dd298afc 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -43,6 +43,8 @@ USE_WX= 2.8+
USE_GETTEXT= yes
+USE_GCC= 4.4+
+
MAN1= \
PTBatcherGUI.1 \
align_image_stack.1 \