aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ida/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-29 21:21:41 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-29 21:21:41 +0800
commit2eac53c12b7df2eb6ba3d18f08a623216da6f83e (patch)
treef36da7a7e670f60030658049ccaab53690fda55a /graphics/ida/Makefile
parent4df414ecacd106ab61c41e0d5d70e1f68942b5aa (diff)
downloadfreebsd-ports-gnome-2eac53c12b7df2eb6ba3d18f08a623216da6f83e.tar.gz
freebsd-ports-gnome-2eac53c12b7df2eb6ba3d18f08a623216da6f83e.tar.zst
freebsd-ports-gnome-2eac53c12b7df2eb6ba3d18f08a623216da6f83e.zip
- fix build for png-1.4.1
- add USE_ICONV to make build with option WITHOUT_NLS=yes
Diffstat (limited to 'graphics/ida/Makefile')
-rw-r--r--graphics/ida/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/graphics/ida/Makefile b/graphics/ida/Makefile
index 45f94621295e..1784f64cf22b 100644
--- a/graphics/ida/Makefile
+++ b/graphics/ida/Makefile
@@ -24,14 +24,21 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
USE_GMAKE= yes
USE_MOTIF= yes
USE_PERL5_BUILD=yes
+USE_ICONV= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
MAKEFILE= ${WRKSRC}/GNUmakefile
+LDLIBS= -liconv
+MAKE_ENV+= LDLIBS="${LDLIBS}"
MAN1= exiftran.1 ida.1
PORTDOCS= README TODO INSTALL
PLIST_FILES= bin/exiftran bin/ida lib/X11/app-defaults/Ida
+post-patch:
+ ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${WRKSRC}/rd/read-png.c
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/exiftran ${PREFIX}/bin
.if !defined(NOPORTDOCS)