aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-08-16 04:37:31 +0800
committermandree <mandree@FreeBSD.org>2014-08-16 04:37:31 +0800
commit58ac4e5adcce1feacac0d197fa1f72c47ff3a751 (patch)
tree3c1641f7451c72c9a9f849082551388e5ddbe65a /graphics/ilmbase
parent6a086c6670a3a9de8049c4ea21005fd70224ae69 (diff)
downloadfreebsd-ports-gnome-58ac4e5adcce1feacac0d197fa1f72c47ff3a751.tar.gz
freebsd-ports-gnome-58ac4e5adcce1feacac0d197fa1f72c47ff3a751.tar.zst
freebsd-ports-gnome-58ac4e5adcce1feacac0d197fa1f72c47ff3a751.zip
Upgrade OpenEXR and ilmbase to 2.2.0.
GCC 4.2 in FreeBSD 8.X/9.X base is now too old to compile OpenEXR, so GCC-based systems will upgrade to the default ports compiler (GCC 4.7 currently.) Add two patches to OpenEXR to permit building it in a live system with the older OpenEXR version installed. Bug report filed to upstream Github at https://github.com/openexr/openexr/issues/130 Couple OpenEXR more tightly to ilmbase and require its exact .so version. Add UPDATING note, and bump PORTREVISION of all dependent ports. Proto-STAGE hugin-devel, and mark it IGNORE because hugin is newer. Approved by: portmgr (implicit for bumping PORTREVISION on unstaged ports)
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile6
-rw-r--r--graphics/ilmbase/distinfo4
-rw-r--r--graphics/ilmbase/files/patch-CMakeLists.txt54
-rw-r--r--graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp11
4 files changed, 28 insertions, 47 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index a71c9854e0b3..f0be63c2d290 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ilmbase
-PORTVERSION= 2.1.0
+PORTVERSION= 2.2.0
CATEGORIES= graphics devel
MASTER_SITES= SAVANNAH/openexr/
DISTNAME= ilmbase-${PORTVERSION}
@@ -22,8 +22,8 @@ OPTIONS_SUB= yes
THREAD_CONFIGURE_ENABLE= threading
-MAJORVER= 2_1
-VER= 11
+MAJORVER= 2_2
+VER= 12
PLIST_SUB= MAJORVER=${MAJORVER}
PLIST_SUB+= VER=${VER}
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
index 23c57d4219be..9d7e0f4ec17b 100644
--- a/graphics/ilmbase/distinfo
+++ b/graphics/ilmbase/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ilmbase-2.1.0.tar.gz) = 1e841ad89c5761940b07a125e6909ad22fe9fe0f99eadef45e0cca4efc6819b4
-SIZE (ilmbase-2.1.0.tar.gz) = 557552
+SHA256 (ilmbase-2.2.0.tar.gz) = ecf815b60695555c1fbc73679e84c7c9902f4e8faa6e8000d2f905b8b86cedc7
+SIZE (ilmbase-2.2.0.tar.gz) = 525289
diff --git a/graphics/ilmbase/files/patch-CMakeLists.txt b/graphics/ilmbase/files/patch-CMakeLists.txt
index dc6d2592137a..4f5419dbabbc 100644
--- a/graphics/ilmbase/files/patch-CMakeLists.txt
+++ b/graphics/ilmbase/files/patch-CMakeLists.txt
@@ -1,50 +1,42 @@
---- CMakeLists.txt.orig 2013-11-12 03:09:51.000000000 +0400
-+++ CMakeLists.txt 2014-03-27 00:26:23.467722879 +0400
-@@ -130,30 +130,30 @@
+--- ./CMakeLists.txt.orig 2014-08-10 06:23:56.000000000 +0200
++++ ./CMakeLists.txt 2014-08-15 02:01:33.000000000 +0200
+@@ -160,30 +160,30 @@
SET_TARGET_PROPERTIES ( Half
PROPERTIES
-- VERSION 11.0.0
-+ VERSION 11
- SOVERSION 11
+- VERSION 12.0.0
++ VERSION 12
+ SOVERSION 12
)
SET_TARGET_PROPERTIES ( Iex
PROPERTIES
-- VERSION 11.0.0
-+ VERSION 11
- SOVERSION 11
- OUTPUT_NAME "Iex-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR}"
+- VERSION 12.0.0
++ VERSION 12
+ SOVERSION 12
+ OUTPUT_NAME "Iex${ILMBASE_LIBSUFFIX}"
)
SET_TARGET_PROPERTIES ( Imath
PROPERTIES
-- VERSION 11.0.0
-+ VERSION 11
- SOVERSION 11
- OUTPUT_NAME "Imath-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR}"
+- VERSION 12.0.0
++ VERSION 12
+ SOVERSION 12
+ OUTPUT_NAME "Imath${ILMBASE_LIBSUFFIX}"
)
SET_TARGET_PROPERTIES ( IlmThread
PROPERTIES
-- VERSION 11.0.0
-+ VERSION 11
- SOVERSION 11
- OUTPUT_NAME "IlmThread-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR}"
+- VERSION 12.0.0
++ VERSION 12
+ SOVERSION 12
+ OUTPUT_NAME "IlmThread${ILMBASE_LIBSUFFIX}"
)
SET_TARGET_PROPERTIES ( IexMath
PROPERTIES
-- VERSION 11.0.0
-+ VERSION 11
- SOVERSION 11
- OUTPUT_NAME "IexMath-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR}"
+- VERSION 12.0.0
++ VERSION 12
+ SOVERSION 12
+ OUTPUT_NAME "IexMath${ILMBASE_LIBSUFFIX}"
)
-@@ -190,11 +190,12 @@
- Name: IlmBase
- Description: Base math and exception libraries
- Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}
--Libs: -L\${libdir} -lImath-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -lIexMath-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -lHalf -lIex-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -lIlmThread-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -pthreadCflags: -pthread -I\${OpenEXR_includedir}
-+Libs: -L\${libdir} -lImath-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -lIexMath-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -lHalf -lIex-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -lIlmThread-${CPACK_PACKAGE_VERSION_MAJOR}_${CPACK_PACKAGE_VERSION_MINOR} -pthread
-+Cflags: -pthread -I\${OpenEXR_includedir}
- ")
-
+@@ -227,5 +227,5 @@
INSTALL ( FILES
${CMAKE_BINARY_DIR}/IlmBase.pc
DESTINATION
diff --git a/graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp b/graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp
deleted file mode 100644
index dbe7a062b958..000000000000
--- a/graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./IexMath/IexMathFpu.cpp.orig 2013-06-18 21:51:38.000000000 +0200
-+++ ./IexMath/IexMathFpu.cpp 2014-01-29 13:16:44.000000000 +0100
-@@ -53,7 +53,7 @@
- #endif
-
-
--#ifdef HAVE_UCONTEXT_H
-+#if defined(HAVE_UCONTEXT_H) && (defined(x86_64) || defined(i386_))
-
-
- #include <ucontext.h>