aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/imageviewer/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-04-13 16:04:41 +0800
committerdinoex <dinoex@FreeBSD.org>2003-04-13 16:04:41 +0800
commit3846d0cc52dc80a1e27e44194e93e43ada87f62f (patch)
tree413f17aa2594c54fbeba82c1f2409095747df8db /graphics/imageviewer/Makefile
parent1ef1a33c8485a1d9c9e1cc638e1f166252d76d1a (diff)
downloadfreebsd-ports-gnome-3846d0cc52dc80a1e27e44194e93e43ada87f62f.tar.gz
freebsd-ports-gnome-3846d0cc52dc80a1e27e44194e93e43ada87f62f.tar.zst
freebsd-ports-gnome-3846d0cc52dc80a1e27e44194e93e43ada87f62f.zip
- Use libobjc.so
- Cleanup - Use bsd.gnustep.mk PR: 50479
Diffstat (limited to 'graphics/imageviewer/Makefile')
-rw-r--r--graphics/imageviewer/Makefile27
1 files changed, 5 insertions, 22 deletions
diff --git a/graphics/imageviewer/Makefile b/graphics/imageviewer/Makefile
index 73bf1ffe1f9d..38bc38eb0f11 100644
--- a/graphics/imageviewer/Makefile
+++ b/graphics/imageviewer/Makefile
@@ -14,36 +14,19 @@ DISTNAME= ImageViewer-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep Image Viewer
-BUILD_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
-
PREFIX= ${LOCALBASE}/GNUstep
+NO_MTREE= yes
WRKSRC= ${WRKDIR}/ImageViewer
GUN_CONFIGURE= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET=
-NO_MTREE= yes
-
-BACKBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-back.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
-.endif
-
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
-
-do-build:
- @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
-
-do-install:
- @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
.include <bsd.port.post.mk>