aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/imlib/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2000-02-27 12:46:33 +0800
committervanilla <vanilla@FreeBSD.org>2000-02-27 12:46:33 +0800
commitd166b51d02e4c535a9e0a80db6f6cd7414a38757 (patch)
tree143b308f5d072809082716d1a55c26ca3eea5a24 /graphics/imlib/Makefile
parent5dcc5fa25757f0cbab8dfa6b07bd0f239def4f20 (diff)
downloadfreebsd-ports-gnome-d166b51d02e4c535a9e0a80db6f6cd7414a38757.tar.gz
freebsd-ports-gnome-d166b51d02e4c535a9e0a80db6f6cd7414a38757.tar.zst
freebsd-ports-gnome-d166b51d02e4c535a9e0a80db6f6cd7414a38757.zip
Remove redundant LIB_DEPENDS,
Use GLIB_CONFIG instead of hardcoded glib12-config PR: ports/16379 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'graphics/imlib/Makefile')
-rw-r--r--graphics/imlib/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 210b8bb56892..c1c07d8c0d03 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -12,20 +12,22 @@ MASTER_SITES= ftp://ftp.enlightenment.org/enlightenment/enlightenment/libs/
MAINTAINER= vanilla@FreeBSD.org
-LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
ungif.5:${PORTSDIR}/graphics/libungif \
gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib \
+ --disable-gtktest
.include <bsd.port.mk>