aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-03-04 04:38:30 +0800
committerasami <asami@FreeBSD.org>2000-03-04 04:38:30 +0800
commitfb14a21d76f4a29efdab086fe7276e55cbba3d35 (patch)
tree38c5fd2ab495eb6edaea7d3ef346f5da1f4e1f6f /graphics/imlib2/Makefile
parent612dc69322519984958de39cbf5971134975aaa3 (diff)
downloadfreebsd-ports-gnome-fb14a21d76f4a29efdab086fe7276e55cbba3d35.tar.gz
freebsd-ports-gnome-fb14a21d76f4a29efdab086fe7276e55cbba3d35.tar.zst
freebsd-ports-gnome-fb14a21d76f4a29efdab086fe7276e55cbba3d35.zip
Add -L${LOCALBASE}/lib in front of -ltiff and stuff in imlib-config;
without it, ports (like astro/xplanet) that only require X-related stuff will fail (since they will only put -L${X11BASE}/lib in the linker command line).
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index c1c07d8c0d03..43cf654facf2 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -30,4 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib \
--disable-gtktest
+pre-configure:
+ ${PERL} -pi -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
+
.include <bsd.port.mk>