aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/inkscape
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-12-20 04:00:55 +0800
committermarcus <marcus@FreeBSD.org>2009-12-20 04:00:55 +0800
commitb5ab5312fa1bc45e1e915668a0dbd05c8249cfd7 (patch)
treef0d4f4e2f1c3f8817961cea9860b8ea54329ac6c /graphics/inkscape
parent5e905f101b004140659d083c505a9aa45ed9a990 (diff)
downloadfreebsd-ports-gnome-b5ab5312fa1bc45e1e915668a0dbd05c8249cfd7.tar.gz
freebsd-ports-gnome-b5ab5312fa1bc45e1e915668a0dbd05c8249cfd7.tar.zst
freebsd-ports-gnome-b5ab5312fa1bc45e1e915668a0dbd05c8249cfd7.zip
Attempt to fix the build on 6.X.
Diffstat (limited to 'graphics/inkscape')
-rw-r--r--graphics/inkscape/Makefile4
-rw-r--r--graphics/inkscape/files/extra-patch-src_document.cpp13
2 files changed, 17 insertions, 0 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 36345e0cf7f4..9aa8c3058ae6 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -57,6 +57,10 @@ CONFIGURE_ARGS+= --enable-poppler-cairo
CONFIGURE_ARGS+= --enable-poppler-cairo=no
.endif
+.if ${OSVERSION} < 700000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_document.cpp
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|ieefp.h|ieeefp.h|' \
${WRKSRC}/src/2geom/bezier-utils.cpp
diff --git a/graphics/inkscape/files/extra-patch-src_document.cpp b/graphics/inkscape/files/extra-patch-src_document.cpp
new file mode 100644
index 000000000000..04f5510b21a3
--- /dev/null
+++ b/graphics/inkscape/files/extra-patch-src_document.cpp
@@ -0,0 +1,13 @@
+--- src/document.cpp.orig 2009-12-19 14:57:53.000000000 -0500
++++ src/document.cpp 2009-12-19 14:59:10.000000000 -0500
+@@ -183,8 +183,8 @@ SPDocument::~SPDocument() {
+
+ if (oldSignalsConnected) {
+ g_signal_handlers_disconnect_by_func(G_OBJECT(INKSCAPE),
+- reinterpret_cast<gpointer>(sp_document_reset_key),
+- static_cast<gpointer>(this));
++ (gpointer)(sp_document_reset_key),
++ (gpointer)(this));
+ } else {
+ _selection_changed_connection.disconnect();
+ _desktop_activated_connection.disconnect();