aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/jasper/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-11-15 18:07:32 +0800
committersobomax <sobomax@FreeBSD.org>2001-11-15 18:07:32 +0800
commit9ec1ffc326c1539c1e3acac4c04d5cebdbb2a5d7 (patch)
tree61773fc5266da3693253fabfed828058f6b8b2c4 /graphics/jasper/Makefile
parentcffc6a46ddf4556412ee89069f614c3eb23ef586 (diff)
downloadfreebsd-ports-gnome-9ec1ffc326c1539c1e3acac4c04d5cebdbb2a5d7.tar.gz
freebsd-ports-gnome-9ec1ffc326c1539c1e3acac4c04d5cebdbb2a5d7.tar.zst
freebsd-ports-gnome-9ec1ffc326c1539c1e3acac4c04d5cebdbb2a5d7.zip
Add Jasper - a reference implementation of the image codec specified in the
JPEG-2000 standard.
Diffstat (limited to 'graphics/jasper/Makefile')
-rw-r--r--graphics/jasper/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
new file mode 100644
index 000000000000..e6f2b68ea942
--- /dev/null
+++ b/graphics/jasper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jasper
+# Date created: 6 November 1994
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jasper
+PORTVERSION= 1.500.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.ece.ubc.ca/~mdadams/jasper/software/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_ZIP= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_ARGS= --enable-shared --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>