aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/jbigkit/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1996-12-23 15:12:29 +0800
committertg <tg@FreeBSD.org>1996-12-23 15:12:29 +0800
commit5aeb814578d6d449ae18a21d9ebb67b8ed5647c9 (patch)
tree8e5005d43609145b191037686a9dcea8e36bad65 /graphics/jbigkit/Makefile
parent44973fc000eda00109ede09c359a4c6b7600209d (diff)
downloadfreebsd-ports-gnome-5aeb814578d6d449ae18a21d9ebb67b8ed5647c9.tar.gz
freebsd-ports-gnome-5aeb814578d6d449ae18a21d9ebb67b8ed5647c9.tar.zst
freebsd-ports-gnome-5aeb814578d6d449ae18a21d9ebb67b8ed5647c9.zip
Import of jbigkit, which contains yet another graphics library.
Closes PR 2066. Submitted by: Mikhail Teterin <mi@aldan.ziplink.net>
Diffstat (limited to 'graphics/jbigkit/Makefile')
-rw-r--r--graphics/jbigkit/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/jbigkit/Makefile b/graphics/jbigkit/Makefile
new file mode 100644
index 000000000000..49c41a381679
--- /dev/null
+++ b/graphics/jbigkit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jbig
+# Version required: 0.9
+# Date created: 19 November 1996
+# Whom: mi
+#
+# $Id$
+#
+
+DISTNAME= jbigkit-0.9
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.informatik.uni-erlangen.de/pub/doc/ISO/JBIG/
+
+MAINTAINER= mi@aldan.ziplink.net
+
+# Yes, CCFLAGS, not CFLAGS! -mi
+MAKE_FLAGS= CCFLAGS="${CFLAGS}" CC="${CC}"
+WRKSRC= work/jbigkit
+MAN1= jbgtopbm.1 pbmtojbg.1
+MAN5= pbm.5
+
+post-build:
+ cd $(WRKSRC); make test
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/jbig
+ ${INSTALL_DATA} ${WRKSRC}/libjbig/jbig.doc ${PREFIX}/share/doc/jbig
+.endif
+ /sbin/ldconfig -m ${PREFIX}/lib
+
+.include <bsd.port.mk>