aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/jpatch
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-06-30 13:44:26 +0800
committerijliao <ijliao@FreeBSD.org>2004-06-30 13:44:26 +0800
commitb66fd2cae36968b0d2b3a325360f21609103c4aa (patch)
tree3bf965972f2d44abc9e4f81f8adbc6aee7637cb0 /graphics/jpatch
parent4321250efedbe7b009062c6c7f631b5831734b3a (diff)
downloadfreebsd-ports-gnome-b66fd2cae36968b0d2b3a325360f21609103c4aa.tar.gz
freebsd-ports-gnome-b66fd2cae36968b0d2b3a325360f21609103c4aa.tar.zst
freebsd-ports-gnome-b66fd2cae36968b0d2b3a325360f21609103c4aa.zip
add jpatch 0.3b1
A spline based 3D modeling tool
Diffstat (limited to 'graphics/jpatch')
-rw-r--r--graphics/jpatch/Makefile32
-rw-r--r--graphics/jpatch/distinfo2
-rw-r--r--graphics/jpatch/files/jpatch3
-rw-r--r--graphics/jpatch/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/graphics/jpatch/Makefile b/graphics/jpatch/Makefile
new file mode 100644
index 000000000000..a8df05bdea27
--- /dev/null
+++ b/graphics/jpatch/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: jpatch
+# Date created: Jun 30, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jpatch
+PORTVERSION= 0.3.b1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.b/beta/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A spline based 3D modeling tool
+
+USE_JAVA= 1.4+
+NO_BUILD= yes
+
+PLIST_FILES= ${JAVAJARDIR:S,^${PREFIX}/,,}/jpatch.jar \
+ bin/jpatch
+
+post-patch:
+ @${SED} 's,%%JAVAJARDIR%%,${JAVAJARDIR},' ${FILESDIR}/jpatch > ${WRKSRC}/jpatch
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/jpatch.jar ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/jpatch ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/jpatch/distinfo b/graphics/jpatch/distinfo
new file mode 100644
index 000000000000..7e42412daad1
--- /dev/null
+++ b/graphics/jpatch/distinfo
@@ -0,0 +1,2 @@
+MD5 (jpatch0.3beta1.tar.gz) = a440e93e0aeb142217c9ec86547142b9
+SIZE (jpatch0.3beta1.tar.gz) = 1995660
diff --git a/graphics/jpatch/files/jpatch b/graphics/jpatch/files/jpatch
new file mode 100644
index 000000000000..03697eee8700
--- /dev/null
+++ b/graphics/jpatch/files/jpatch
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -jar %%JAVAJARDIR%%/jpatch.jar
diff --git a/graphics/jpatch/pkg-descr b/graphics/jpatch/pkg-descr
new file mode 100644
index 000000000000..f0fa6117f04f
--- /dev/null
+++ b/graphics/jpatch/pkg-descr
@@ -0,0 +1,4 @@
+Patch is a spline based 3D modeling tool. It allows to create 3D models which
+can be rendered with POV-Ray or RenderMan compatible renderers (e.g. Aqsis).
+
+WWW: http://jpatch.sourceforge.net/