aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/juno-2
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-10-17 03:03:25 +0800
committererwin <erwin@FreeBSD.org>2006-10-17 03:03:25 +0800
commitb6afb57de574b2b42df79851a757f796e377983b (patch)
tree74d38e2d91b97ad8af32e40a68bac7ca172bba3a /graphics/juno-2
parent2c5ec45b9efb7799a85eba1b1e810665346aa368 (diff)
downloadfreebsd-ports-gnome-b6afb57de574b2b42df79851a757f796e377983b.tar.gz
freebsd-ports-gnome-b6afb57de574b2b42df79851a757f796e377983b.tar.zst
freebsd-ports-gnome-b6afb57de574b2b42df79851a757f796e377983b.zip
Use INST_TARGET instead of TARGETDIR locally to avoid conflicting
with bsd.ports.mk's TARGETDIR macro. Submitted by: kris Inspired by: gabor Approved by: portmgr (self)
Diffstat (limited to 'graphics/juno-2')
-rw-r--r--graphics/juno-2/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/juno-2/Makefile b/graphics/juno-2/Makefile
index ae51c72a25a4..2a625fce5117 100644
--- a/graphics/juno-2/Makefile
+++ b/graphics/juno-2/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${L1}libm3netobj${L2}:${PORTSDIR}/lang/pm3-netobj \
MAN1= Juno.1
PLIST_SUB+= SOVERSION=${SOVERSION} TARGET=${TARGET} \
- TARGETDIR=${TARGETDIR} WORDSIZE=${WORDSIZE}
+ INST_TARGET=${INST_TARGET} WORDSIZE=${WORDSIZE}
BUILD1= juno-machine \
juno-compiler
@@ -39,16 +39,16 @@ EXAMPLESDIR= ${PREFIX}/share/examples/Juno
.if ${PORTOBJFORMAT} == "aout"
L2= .so.${SOVERSION}.0
TARGET= FreeBSD2
-TARGETDIR= freebsd-2
+INST_TARGET= freebsd-2
WORDSIZE= 32
.elif ${ARCH} == "i386"
L2= .so.${SOVERSION}
.if ${OSVERSION} < 400011
TARGET= FreeBSD3
-TARGETDIR= freebsd-3
+INST_TARGET= freebsd-3
.else
TARGET= FreeBSD4
-TARGETDIR= freebsd-4
+INST_TARGET= freebsd-4
.endif
WORDSIZE= 32
.elif ${ARCH} == "alpha"
@@ -58,7 +58,7 @@ IGNORE= not supported on older versions of FreeBSD/Alpha
CFLAGS+= -mieee
L2= .so.${SOVERSION}
TARGET= FBSD_ALPHA
-TARGETDIR= fbsd-alpha
+INST_TARGET= fbsd-alpha
WORDSIZE= 64
.endif