aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/kallery/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2002-10-25 11:06:34 +0800
committeradamw <adamw@FreeBSD.org>2002-10-25 11:06:34 +0800
commitfb9f070070bb5c7fa643d4f0cf95e8426e2bb175 (patch)
treeb57908c5a47ee36d8901ccd300e4029a59249c56 /graphics/kallery/Makefile
parent236ee932b2634eabc44196c1ef7a6245b650311c (diff)
downloadfreebsd-ports-gnome-fb9f070070bb5c7fa643d4f0cf95e8426e2bb175.tar.gz
freebsd-ports-gnome-fb9f070070bb5c7fa643d4f0cf95e8426e2bb175.tar.zst
freebsd-ports-gnome-fb9f070070bb5c7fa643d4f0cf95e8426e2bb175.zip
Add graphics/kallery
An image gallery generator for KDE PR: 43280 Submitted by: metrol@metrol.net Approved by: pat
Diffstat (limited to 'graphics/kallery/Makefile')
-rw-r--r--graphics/kallery/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/kallery/Makefile b/graphics/kallery/Makefile
new file mode 100644
index 000000000000..e058277216cd
--- /dev/null
+++ b/graphics/kallery/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: kallery
+# Date created: 22 September 2002
+# Whom: Michael Collette
+#
+# $FreeBSD$
+#
+
+PORTNAME= kallery
+PORTVERSION= 1.0.2
+CATEGORIES= graphics kde
+MASTER_SITES= http://www.virtualartisans.com/kde/andras/kallery/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= metrol@metrol.net
+
+LIB_DEPENDS= Magick.5:${PORTSDIR}/graphics/ImageMagick
+
+USE_KDELIBS_VER=3
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+= --prefix=${LOCALBASE}
+
+post-patch:
+.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -Ee \
+ 's|(dtd/kdex.dtd)|${LOCALBASE}/share/apps/ksgmltools2/customization/\1|' \
+ ${WRKSRC}/doc/en/index.docbook
+.else
+ @${REINPLACE_CMD} -Ee 's|(kallery po) doc|\1|' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>