aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/kdegraphics4/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-08-19 08:04:22 +0800
committerolgeni <olgeni@FreeBSD.org>2001-08-19 08:04:22 +0800
commit77c575302597cac7ba0731230dd10355c1a3df60 (patch)
tree7ef3ec1ed845bda84f6e888590fa4de00eca1cd6 /graphics/kdegraphics4/Makefile
parent820572e359846332a3c238141f53f99385124b0a (diff)
downloadfreebsd-ports-gnome-77c575302597cac7ba0731230dd10355c1a3df60.tar.gz
freebsd-ports-gnome-77c575302597cac7ba0731230dd10355c1a3df60.tar.zst
freebsd-ports-gnome-77c575302597cac7ba0731230dd10355c1a3df60.zip
Add the WITH_SANE option to include sane-backends as dependency, and
compile the Kooka application. Also, temporarily disable compilation of the Kamera stuff, which requires gphoto2, and leave a hint in pkg-plist to enable it later (I know it's ugly but it should at least get binary packages up and running for most people).
Diffstat (limited to 'graphics/kdegraphics4/Makefile')
-rw-r--r--graphics/kdegraphics4/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 7e45e7e60be7..deb7acfdb602 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -16,11 +16,24 @@ MAINTAINER= will@FreeBSD.org
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
+# temporarily disable kamera, it requires gphoto2
+PLIST_SUB+= KAMERA:="@comment "
+
+.if defined(WITH_SANE)
+LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends
+PLIST_SUB+= SANE:=""
+.else
+PLIST_SUB+= SANE:="@comment "
+pre-everything::
+ @${ECHO_MSG} "===> If you want to compile this port with scanner support, use \"make WITH_SANE=yes\""
+.endif
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+CONFIGURE_ARGS+=--without-kamera
pre-configure:
${PERL} -pi -e "s@libkscan_la_LIBADD =@libkscan_la_LIBADD= -lintl@g" ${WRKSRC}/libkscan/Makefile.in