aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/kdegraphics4/Makefile
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>1998-02-21 23:09:22 +0800
committerse <se@FreeBSD.org>1998-02-21 23:09:22 +0800
commit60c9b59b866ab0af45aa84fcb53894451f4c5577 (patch)
treee0164f49faf1cd38172a37cd4141650f9e82cd8a /graphics/kdegraphics4/Makefile
parent80068ab356cd1e2d911a4614ca645166a06699ef (diff)
downloadfreebsd-ports-gnome-60c9b59b866ab0af45aa84fcb53894451f4c5577.tar.gz
freebsd-ports-gnome-60c9b59b866ab0af45aa84fcb53894451f4c5577.tar.zst
freebsd-ports-gnome-60c9b59b866ab0af45aa84fcb53894451f4c5577.zip
The KDE graphics utilities (at Beta3):
- kdvi only useful with TeX ... - kfax FAX tool - kfract fractals generator - kghostview only useful with ghostscript - kpaint simple paint program - kview graphics file viewer
Diffstat (limited to 'graphics/kdegraphics4/Makefile')
-rw-r--r--graphics/kdegraphics4/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
new file mode 100644
index 000000000000..3c8c4c2ca51c
--- /dev/null
+++ b/graphics/kdegraphics4/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: kdegraphics
+# Version required: Beta1
+# Date created: 28 October 1997
+# Whom: Stefan Eßer <se@freebsd.org>
+#
+# $Id:$
+#
+
+DISTNAME= kdegraphics-Beta3-1
+PKGNAME= kdegraphics-3.1b
+CATEGORIES= graphics kde
+MASTER_SITES= ftp://ftp.net.lut.ac.uk/kde/stable/Beta3/distribution/tgz/source/ \
+ ftp://ftp.uni-erlangen.de/pub/Linux/MIRROR.KDE/stable/Beta3/distribution/tgz/source/ \
+ ftp://ftp.caldera.com/pub/mirrors/kde/stable/Beta3/distribution/tgz/source/
+EXTRACT_SUFX= .src.tar.gz
+
+MAINTAINER= se@freebsd.org
+
+LIB_DEPENDS= qt\\.1\\.3[1-9]:${PORTSDIR}/x11/qt \
+ gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+ jpeg\\.[67]\\.:${PORTSDIR}/graphics/jpeg \
+ kdecore\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ kdeui\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
+ jscript\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ khtmlw\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
+ kfm\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ mediatool\\.0\\.[6-9]:${PORTSDIR}/x11/kdelibs
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
+ "--with-extra-includes=$(PREFIX)/include/giflib"
+
+CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
+ INSTALL_SCRIPT="install -c -m 555"
+
+WRKSRC= ${WRKDIR}/kdegraphics
+USE_GMAKE= yes
+
+.include <bsd.port.mk>