aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/kdegraphics4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-04 04:10:37 +0800
committermakc <makc@FreeBSD.org>2013-02-04 04:10:37 +0800
commit751b41dafeebc053115ea65f18c9ab0a009b0237 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /graphics/kdegraphics4
parent021b3043f8ab11aaff1bb422f34a0dd5dd655cd0 (diff)
downloadfreebsd-ports-gnome-751b41dafeebc053115ea65f18c9ab0a009b0237.tar.gz
freebsd-ports-gnome-751b41dafeebc053115ea65f18c9ab0a009b0237.tar.zst
freebsd-ports-gnome-751b41dafeebc053115ea65f18c9ab0a009b0237.zip
KDE/FreeBSD team presents KDE SC 4.9.5 ports!
- kdebindings ports have been renamed to match upstream. - kdemultimedia and kdenetwork have been split. - New port games/pairs added. - Trim Makefile header - Convert to new option framework - New USE_KDE4 components: libkcddb, libkcompactdisc - Update: databases/akonadi to 1.9.0 devel/grantlee to 0.3.0 textproc/rasqal to 0.9.30 textproc/redland-bindings to 1.0.16.1 textproc/soprano to 2.9.0 x11-toolkits/attica to 0.4.1 The area51 repository features commits by Schaich Alonso, avilla, dbn, jhale, makc and rakuco. Contributors: - Oleg Sidorkin - Tobias Berner - Kurt Jaeger
Diffstat (limited to 'graphics/kdegraphics4')
-rw-r--r--graphics/kdegraphics4/Makefile45
1 files changed, 23 insertions, 22 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index f196905e51f2..fafbf2683cf0 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: kdegraphics
-# Date created: 2008-01-31
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= kdegraphics
@@ -23,51 +20,55 @@ LATEST_LINK= ${PORTNAME}4
USE_KDE4= kdeprefix
NO_BUILD= yes
-OPTIONS= GPHOTO2 "Digital camera manager" on \
- GWENVIEW "Image viewer and browser" on \
- KCOLORCHOOSER "Utility for colors selection" on \
- KGAMMA "Monitor calibration tool" on \
- KRULER "Screen ruler" on \
- KOLOURPAINT "Paint application" on \
- KSNAPSHOT "Screen capture program" on \
- OKULAR "Universal document viewer" on \
- SANE "Plugin for scanning on KDE" on
+OPTIONS_DEFINE= GPHOTO GWENVIEW KCOLORCHOOSER KGAMMA KRULER \
+ KOLOURPAINT KSNAPSHOT OKULAR SANE
+OPTIONS_DEFAULT=${OPTIONS_DEFINE}
+
+GPHOTO_DESC= Digital camera manager
+GWENVIEW_DESC= Image viewer and browser
+KCOLORCHOOSER_DESC= Utility for colors selection
+KGAMMA_DESC= Monitor calibration tool
+KRULER_DESC= Screen ruler
+KOLOURPAINT_DESC= Paint application
+KSNAPSHOT_DESC= Screen capture program
+OKULAR_DESC= Universal document viewer
+SANE_DESC= Plugin for scanning on KDE
.include <bsd.port.options.mk>
-.ifndef(WITHOUT_GPHOTO2)
+.if ${PORT_OPTIONS:MGPHOTO}
RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/kio_kamera.so:${PORTSDIR}/graphics/kamera-kde4
.endif
-.ifndef(WITHOUT_GWENVIEW)
+.if ${PORT_OPTIONS:MGWENVIEW}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/gwenview:${PORTSDIR}/graphics/gwenview-kde4
.endif
-.ifndef(WITHOUT_KCOLORCHOOSER)
+.if ${PORT_OPTIONS:MKCOLORCHOOSER}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kcolorchooser:${PORTSDIR}/graphics/kcolorchooser
.endif
-.ifndef(WITHOUT_KGAMMA)
+.if ${PORT_OPTIONS:MKGAMMA}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/xf86gammacfg:${PORTSDIR}/x11/kgamma
.endif
-.ifndef(WITHOUT_KRULER)
+.if ${PORT_OPTIONS:MKRULER}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kruler:${PORTSDIR}/deskutils/kruler
.endif
-.ifndef(WITHOUT_KOLOURPAINT)
+.if ${PORT_OPTIONS:MKOLOURPAINT}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kolourpaint:${PORTSDIR}/graphics/kolourpaint
.endif
-.ifndef(WITHOUT_KSNAPSHOT)
+.if ${PORT_OPTIONS:MKSNAPSHOT}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/ksnapshot:${PORTSDIR}/graphics/ksnapshot
.endif
-.ifndef(WITHOUT_OKULAR)
+.if ${PORT_OPTIONS:MOKULAR}
USE_KDE4+= okular_run
.endif
-.ifndef(WITHOUT_SANE)
+.if ${PORT_OPTIONS:MSANE}
RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/ksaneplugin.so:${PORTSDIR}/graphics/ksaneplugin
.endif