aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/kdiagram/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /graphics/kdiagram/Makefile
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'graphics/kdiagram/Makefile')
-rw-r--r--graphics/kdiagram/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/kdiagram/Makefile b/graphics/kdiagram/Makefile
index a6199bbfbef7..23c73288ce45 100644
--- a/graphics/kdiagram/Makefile
+++ b/graphics/kdiagram/Makefile
@@ -13,7 +13,7 @@ COMMENT= Library to create business diagrams
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.GPL.txt
-USES= cmake:outsource compiler:c++11-lang kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= ecm
USE_QT= core gui linguisttools printsupport sql svg widgets \
buildtools_build qmake_build