aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/lcms/files
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-24 03:08:26 +0800
committerkrion <krion@FreeBSD.org>2004-05-24 03:08:26 +0800
commite0871d41707480faf65404ee8b3e2429b5fd6586 (patch)
treef384babd2ba9f826e655444f543cf1d2fa882f59 /graphics/lcms/files
parentd0f3b1929b6d09132929a45aef180da5d1cb7d3e (diff)
downloadfreebsd-ports-gnome-e0871d41707480faf65404ee8b3e2429b5fd6586.tar.gz
freebsd-ports-gnome-e0871d41707480faf65404ee8b3e2429b5fd6586.tar.zst
freebsd-ports-gnome-e0871d41707480faf65404ee8b3e2429b5fd6586.zip
- Update to version 1.12
PR: ports/67083 Submitted by: Ports Fury
Diffstat (limited to 'graphics/lcms/files')
-rw-r--r--graphics/lcms/files/Makefile.bsd18
-rw-r--r--graphics/lcms/files/patch-32bit4
-rw-r--r--graphics/lcms/files/patch-config14
-rw-r--r--graphics/lcms/files/patch-icc3413
4 files changed, 17 insertions, 32 deletions
diff --git a/graphics/lcms/files/Makefile.bsd b/graphics/lcms/files/Makefile.bsd
deleted file mode 100644
index 46bfc1f27a42..000000000000
--- a/graphics/lcms/files/Makefile.bsd
+++ /dev/null
@@ -1,18 +0,0 @@
-LIB=lcms
-SHLIB_MAJOR= 1
-SHLIB_MINOR= 9
-
-SRCS!= make -V SRCS
-
-NOPROFILE=YES
-
-INCS= ${.CURDIR}/../include/lcms.h ${.CURDIR}/../include/icc34.h
-
-CFLAGS+= -I${.CURDIR}/../include
-LDADD+= -lm
-
-INCSDIR=${LOCALBASE}/include
-INCDIR= ${INCSDIR} # for 4.x bsd.lib.mk
-LIBDIR= ${LOCALBASE}/lib
-
-.include <bsd.lib.mk>
diff --git a/graphics/lcms/files/patch-32bit b/graphics/lcms/files/patch-32bit
index 1090667ce8e2..d46710470240 100644
--- a/graphics/lcms/files/patch-32bit
+++ b/graphics/lcms/files/patch-32bit
@@ -1,8 +1,8 @@
This patch fixes assumptions made in different parts of the code
regarding the sizeof long and int. The original code appears to use them
interchangeably, even though it expects them to be 32 bit wide.
---- cmsmtrx.c Tue Feb 13 12:08:06 2001
-+++ cmsmtrx.c Wed Sep 5 10:28:02 2001
+--- src/cmsmtrx.c Tue Feb 13 12:08:06 2001
++++ src/cmsmtrx.c Wed Sep 5 10:28:02 2001
@@ -705,6 +705,6 @@
void VEC3scaleAndCut(LPWVEC3 r, LPVEC3 v, double d)
{
diff --git a/graphics/lcms/files/patch-config b/graphics/lcms/files/patch-config
index 85e60a1d4ddb..9236abc18b51 100644
--- a/graphics/lcms/files/patch-config
+++ b/graphics/lcms/files/patch-config
@@ -1,15 +1,17 @@
---- ../include/lcms.h Wed Aug 7 15:34:37 2002
-+++ ../include/lcms.h Wed Nov 6 01:23:21 2002
-@@ -66,5 +73,11 @@
+--- include/lcms.h.orig Sun Dec 21 00:00:11 2003
++++ include/lcms.h Sun May 23 12:14:22 2004
+@@ -52,7 +52,13 @@
+
// Uncomment this one if you are using big endian machines (only meaningful
// when NON_WINDOWS is used)
-// #define USE_BIG_ENDIAN 1
+
-+#include <machine/endian.h>
++#include <sys/endian.h>
+#if BYTE_ORDER == BIG_ENDIAN
-+# define USE_BIG_ENDIAN 1
++# define USE_BIG_ENDIAN 1
+#elif BYTE_ORDER != LITTLE_ENDIAN
-+# error "Unexpected BYTE_ORDER on this architecture"
++# error "Unexpected BYTE_ORDER on this architecture"
+#endif
// Uncomment this one if your compiler/machine does support the
+ // "long long" type This will speedup fixed point math. (USE_C only)
diff --git a/graphics/lcms/files/patch-icc34 b/graphics/lcms/files/patch-icc34
index 21b8d5b18cc0..6d7a4aa9b2e5 100644
--- a/graphics/lcms/files/patch-icc34
+++ b/graphics/lcms/files/patch-icc34
@@ -1,13 +1,14 @@
Try to use the int32 and friends on all Unixes -- not just SGI's Irix.
---- ../include/icc34.h Tue Feb 13 12:08:06 2001
-+++ ../include/icc34.h Wed Sep 5 10:08:42 2001
-@@ -144,7 +144,9 @@
- */
-
+--- include/icc34.h.in.orig Tue Jul 22 06:10:02 2003
++++ include/icc34.h.in Sun May 23 11:45:09 2004
+@@ -191,8 +191,10 @@
+ typedef icUInt32Number icU16Fixed16Number;
+
+ #else
+#ifdef __unix__
#ifdef __sgi
#include "sgidefs.h"
+#endif
- typedef __int32_t icSignature;
+ typedef __int32_t icSignature;