aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/lensfun
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-16 02:42:10 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-16 02:42:10 +0800
commit691eea0f2ac6ed060ef3993d1a4cd1d7b45482fc (patch)
tree9953b46844c6b057f5730545afdfeeb331dcb0ad /graphics/lensfun
parent2c51e63307216d8c9675d5ff7ea5648b7ac0be29 (diff)
downloadfreebsd-ports-gnome-691eea0f2ac6ed060ef3993d1a4cd1d7b45482fc.tar.gz
freebsd-ports-gnome-691eea0f2ac6ed060ef3993d1a4cd1d7b45482fc.tar.zst
freebsd-ports-gnome-691eea0f2ac6ed060ef3993d1a4cd1d7b45482fc.zip
Unbreak the build against new Clang version 6.0.0 (due to the same nature
of the changes, should've been part of r459108). PR: 224989
Diffstat (limited to 'graphics/lensfun')
-rw-r--r--graphics/lensfun/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index 0a00f32df16b..207403b64771 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -32,4 +32,8 @@ PYHELPERS_CMAKE_ON= -DSTAGEDIR:STRING=${STAGEDIR} -DPYTHON:STRING=${PYTHON_CMD}
PYHELPERS_CMAKE_OFF= -DINSTALL_HELPER_SCRIPTS:BOOL=OFF -DPYTHON:STRING=IGNORE
PYHELPERS_USES= python:3.4+
+post-patch:
+# Fix the build against Clang 6.0.0
+ @${REINPLACE_CMD} -e '/%%/s,R_BX, & ,' ${WRKSRC}/libs/lensfun/cpuid.cpp
+
.include <bsd.port.mk>