aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/lensfun
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-03-31 16:08:49 +0800
committerdanfe <danfe@FreeBSD.org>2015-03-31 16:08:49 +0800
commit3cb99bc8efe209f913388a0d8d3e4d2eb473d8cf (patch)
tree6a193b173825c40bc704c593793e1f248421a96d /graphics/lensfun
parent4b3f5419983c5609feb5d986659b18593ec18c28 (diff)
downloadfreebsd-ports-gnome-3cb99bc8efe209f913388a0d8d3e4d2eb473d8cf.tar.gz
freebsd-ports-gnome-3cb99bc8efe209f913388a0d8d3e4d2eb473d8cf.tar.zst
freebsd-ports-gnome-3cb99bc8efe209f913388a0d8d3e4d2eb473d8cf.zip
Update lensfun to version 0.3.0. It contains few changes making consumer
code incompatible with earlier versions; particularly, removal of CCI (the Color Contribution Index of the lens, as defined by ISO 6728-83) [1] and FOV1 ("field-of-view") [2] distortion model. Four ports had to be patched to build against new lensfun (all fall under `graphics' category): digikam-kde4, gimp-lensfun-plugin, hugin, rawstudio. PR: 196182 Submitted by: Matthieu Volat (heavily modified) Exp-run by: antoine [1] https://sourceforge.net/p/lensfun/code/ci/f0c293 [2] https://sourceforge.net/p/lensfun/code/ci/048eb3
Diffstat (limited to 'graphics/lensfun')
-rw-r--r--graphics/lensfun/Makefile32
-rw-r--r--graphics/lensfun/distinfo4
-rw-r--r--graphics/lensfun/files/patch-CMakeLists.txt28
-rw-r--r--graphics/lensfun/pkg-plist18
4 files changed, 52 insertions, 30 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index ff2f56d93675..a01747c84230 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lensfun
-PORTVERSION= 0.2.8
-PORTREVISION= 1
+PORTVERSION= 0.3.0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
@@ -14,32 +13,13 @@ LICENSE= LGPL3
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-USES= gmake pkgconfig python:build tar:bzip2
+USES= cmake pkgconfig tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
+CMAKE_ARGS= -DBUILD_AUXFUN:BOOL=ON -DINSTALL_HELPER_SCRIPTS:BOOL=OFF
-HAS_CONFIGURE= yes
-CONFIGURE_ENV= LD="${CXX}" AR="${AR}"
-CONFIGURE_ARGS= --prefix=${PREFIX} --target=${TARGET} --vectorization=SSE
-MAKE_ARGS= V=1 # we want to know what's going on during the build
-MAKEFILE= GNUmakefile
-LIBVERSION= 2
-
-PLIST_SUB+= LIBVERSION=${LIBVERSION}
-
-post-patch: .SILENT
- ${REINPLACE_CMD} -e '1s|#!/usr/bin/python|#!${PYTHON_CMD}|' \
- -e 's|make --version|g&|' -e '/DOXYGEN/d' \
- -e '/GNU Make/d' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e \
- 's|CONF_LIBDIR)pkgconfig|CONF_LIBDIR)../libdata/pkgconfig|' \
- ${WRKSRC}/build/tibs/compiler/pkgconfig.mak
- ${REINPLACE_CMD} -e '/-s -O3/d' \
- ${WRKSRC}/build/tibs/compiler/gcc.mak
- ${REINPLACE_CMD} -e '/GROUPS/s| DOCS||' ${WRKSRC}/build/tibs/rules.mak
-
-post-install:
- ${LN} -sf lib${PORTNAME}.so \
- ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so.${LIBVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e '/pkgconfig/s,$${LIBDIR},libdata,' \
+ ${WRKSRC}/libs/lensfun/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/graphics/lensfun/distinfo b/graphics/lensfun/distinfo
index a8a634e93db1..daf4ceb48c0e 100644
--- a/graphics/lensfun/distinfo
+++ b/graphics/lensfun/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lensfun-0.2.8.tar.bz2) = f88f97fbc78259a2b2edddef295caf50770901107c8469e54bb5e9699faa1a48
-SIZE (lensfun-0.2.8.tar.bz2) = 628913
+SHA256 (lensfun-0.3.0.tar.bz2) = c2c3c03873cb549d49d42f118fcb0ffa95d1e45b9ff395e19facb63bf699bec1
+SIZE (lensfun-0.3.0.tar.bz2) = 636694
diff --git a/graphics/lensfun/files/patch-CMakeLists.txt b/graphics/lensfun/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..aa0ae96253fa
--- /dev/null
+++ b/graphics/lensfun/files/patch-CMakeLists.txt
@@ -0,0 +1,28 @@
+--- CMakeLists.txt.orig 2014-09-30 17:37:34 UTC
++++ CMakeLists.txt
+@@ -46,15 +46,11 @@ ENDIF()
+
+ IF(BUILD_FOR_SSE)
+ SET(VECTORIZATION_SSE 1)
+- IF(CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse")
+- ENDIF()
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse")
+ ENDIF()
+ IF(BUILD_FOR_SSE2)
+ SET(VECTORIZATION_SSE2 1)
+- IF(CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2")
+- ENDIF()
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2")
+ ENDIF()
+
+ IF(WIN32)
+@@ -68,6 +64,7 @@ ENDIF()
+ # find dependencies
+ FIND_PACKAGE(GLIB2 REQUIRED)
+ INCLUDE_DIRECTORIES(${GLIB2_INCLUDE_DIRS})
++LINK_DIRECTORIES(${GLIB2_LIBRARY_DIRS})
+
+ IF(BUILD_AUXFUN)
+ FIND_PACKAGE(PNG REQUIRED)
diff --git a/graphics/lensfun/pkg-plist b/graphics/lensfun/pkg-plist
index a0fd3934c3f6..94704bcd04a6 100644
--- a/graphics/lensfun/pkg-plist
+++ b/graphics/lensfun/pkg-plist
@@ -1,11 +1,18 @@
-include/lensfun.h
+include/auxfun/image.h
+include/auxfun/rgbpixel.h
+include/lensfun/lensfun.h
+lib/libauxfun.so
+lib/libauxfun.so.0
+lib/libauxfun.so.0.3.0
lib/liblensfun.so
-lib/liblensfun.so.%%LIBVERSION%%
+lib/liblensfun.so.0
+lib/liblensfun.so.0.3.0
libdata/pkgconfig/lensfun.pc
%%DATADIR%%/6x6.xml
%%DATADIR%%/compact-canon.xml
%%DATADIR%%/compact-casio.xml
%%DATADIR%%/compact-fujifilm.xml
+%%DATADIR%%/compact-gopro.xml
%%DATADIR%%/compact-kodak.xml
%%DATADIR%%/compact-konica-minolta.xml
%%DATADIR%%/compact-leica.xml
@@ -23,10 +30,13 @@ libdata/pkgconfig/lensfun.pc
%%DATADIR%%/mil-nikon.xml
%%DATADIR%%/mil-olympus.xml
%%DATADIR%%/mil-panasonic.xml
+%%DATADIR%%/mil-pentax.xml
%%DATADIR%%/mil-samsung.xml
%%DATADIR%%/mil-samyang.xml
%%DATADIR%%/mil-sigma.xml
%%DATADIR%%/mil-sony.xml
+%%DATADIR%%/mil-zeiss.xml
+%%DATADIR%%/misc.xml
%%DATADIR%%/rf-leica.xml
%%DATADIR%%/slr-canon.xml
%%DATADIR%%/slr-contax.xml
@@ -37,6 +47,7 @@ libdata/pkgconfig/lensfun.pc
%%DATADIR%%/slr-olympus.xml
%%DATADIR%%/slr-panasonic.xml
%%DATADIR%%/slr-pentax.xml
+%%DATADIR%%/slr-ricoh.xml
%%DATADIR%%/slr-samsung.xml
%%DATADIR%%/slr-samyang.xml
%%DATADIR%%/slr-schneider.xml
@@ -46,3 +57,6 @@ libdata/pkgconfig/lensfun.pc
%%DATADIR%%/slr-tamron.xml
%%DATADIR%%/slr-tokina.xml
%%DATADIR%%/slr-ussr.xml
+%%DATADIR%%/slr-vivitar.xml
+%%DATADIR%%/slr-zeiss.xml
+%%DATADIR%%/timestamp.txt