aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libEGL
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-10-17 17:53:13 +0800
committerkwm <kwm@FreeBSD.org>2014-10-17 17:53:13 +0800
commitd6afb37e19f66eed665826275fba54cca09a8c89 (patch)
tree10eadf882ac174da154c3fda250d8872d4fa1acc /graphics/libEGL
parent4bc9e1fc7d12f2e377422acc4d926720bde09698 (diff)
downloadfreebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.tar.gz
freebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.tar.zst
freebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.zip
Update Mesa ports to new default of 9.1.7 and more recent version to 10.3.0.
The port will switch to the newer version if hw context is available in the i915kms driver. - Get ride of WITH_NEW_XORG. - Use @comment in plist to ignore unwanted files in the stagedir, instead of trying to remove them in post-install. - Bump portrevision of 9.1.7 due to dependency changes. - Drop :keepla from USES=libtool. - Drop @dirrm[try] from plists - Give dri propper options, with pkg-help for additional information. - Make separate plist for dri for the different versions, the combined plist was headache inducing. - Add "workaround" patches to allow clang to build the dri port on i386 [1]. USE_GCC is now only needed for 8.x. - Add gbm port and USE_GL switch for it. PR: 192286 [1] Submitted by: Carlos Jacobo Puga Medina [1] Approved by: portmgr (bapt@) In collaberation with: dumbbell@ Obtained from: xorg-dev
Diffstat (limited to 'graphics/libEGL')
-rw-r--r--graphics/libEGL/Makefile44
-rw-r--r--graphics/libEGL/pkg-plist4
2 files changed, 36 insertions, 12 deletions
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
index 340d18969796..9819cd90f060 100644
--- a/graphics/libEGL/Makefile
+++ b/graphics/libEGL/Makefile
@@ -3,28 +3,54 @@
PORTNAME= libEGL
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 3
+PORTREVISION= ${LIBEGL_REVISION}
CATEGORIES= graphics
COMMENT= OpenEGL library
-LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
+LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libdevq.so:${PORTSDIR}/devel/libdevq \
+ libdrm.so:${PORTSDIR}/graphics/libdrm
USE_XORG= x11 xau xcb xdmcp
# stuff not needed by libEGL but configure wants it
-USE_XORG+= glproto dri2proto xext xdamage xfixes
-LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
- libdrm.so:${PORTSDIR}/graphics/libdrm
+USE_XORG+= glproto dri2proto xext xdamage xfixes presentproto \
+ xshmfence
+
+.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
+.if defined(WITH_NEW_MESA)
+BUILD_WRKSRC= src/egl/drivers/dri2 src/egl/main
+INSTALL_WRKSRC= src/egl/drivers/dri2 src/egl/main
+.else
BUILD_WRKSRC= ${WRKSRC}/src/egl
INSTALL_WRKSRC= ${WRKSRC}/src/egl
+.endif
-.include <bsd.port.options.mk>
+.if defined(WITH_NEW_MESA)
+LIBEGL_REVISION= 0
+.else
+LIBEGL_REVISION= 4
+.endif
+
+.if defined(WITH_NEW_MESA)
+do-build: egl-do-build
+do-install: egl-do-install
-.if ! defined(WITH_NEW_XORG)
-IGNORE= Please enable WITH_NEW_XORG, libEGL needs libdrm higher then 2.4.24
+egl-do-build:
+. for dir in ${BUILD_WRKSRC}
+ @(cd ${WRKSRC}/${dir}; ${DO_MAKE_BUILD} ${ALL_TARGET};)
+. endfor
+
+egl-do-install:
+. for dir in ${INSTALL_WRKSRC}
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+. endfor
.endif
-.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
.include <bsd.port.mk>
diff --git a/graphics/libEGL/pkg-plist b/graphics/libEGL/pkg-plist
index e5a8156f0334..fb478a869f65 100644
--- a/graphics/libEGL/pkg-plist
+++ b/graphics/libEGL/pkg-plist
@@ -1,12 +1,10 @@
include/EGL/egl.h
include/EGL/eglext.h
+%%NEW%%include/EGL/eglextchromium.h
include/EGL/eglmesaext.h
include/EGL/eglplatform.h
include/KHR/khrplatform.h
-lib/libEGL.la
lib/libEGL.so
lib/libEGL.so.1
lib/libEGL.so.1.0.0
libdata/pkgconfig/egl.pc
-@dirrmtry include/KHR
-@dirrmtry include/EGL