aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libGL/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-05-17 17:56:00 +0800
committerkwm <kwm@FreeBSD.org>2014-05-17 17:56:00 +0800
commitf1daeca7a40c82d284988efd4457ade0008e0af5 (patch)
treee9172feaf552da3dbe353c195227e5c9d143116e /graphics/libGL/Makefile
parentef3773edadd26fc9aa4293f7714b20df086a6e11 (diff)
downloadfreebsd-ports-gnome-f1daeca7a40c82d284988efd4457ade0008e0af5.tar.gz
freebsd-ports-gnome-f1daeca7a40c82d284988efd4457ade0008e0af5.tar.zst
freebsd-ports-gnome-f1daeca7a40c82d284988efd4457ade0008e0af5.zip
Enable shared libglapi library and make a port for it. It is used by libGL
and libglesv2. This fixes undefined symbol issues in libglesv2. Clean up stagedir of unwanted files/directories, so check-plist passes. Switch logic and always build gallium support in graphics/dri on i386 and amd64. Gallium is used for Radeon HD 5000+ support. Use USES=tar:bzip2 Under WITH_NEW_XORG: Add patch to remove some dependencies for aclocal.m4 which are absent. This allows the removal of USE_AUTOTOOLS, REAPPLY_PATCHES and pre-configure target. Add INSTALL_TARGET=install-strip to strip libraries. USES=libtool:keepla Fix a /use typo with /usr in post-patch. Bump PORTREVISION for the libtool and libglapi changes. Submitted by: tijl@ (libtool and autotools changes) Obtained from: xorg-dev repo (libglapi and gallium changes)
Diffstat (limited to 'graphics/libGL/Makefile')
-rw-r--r--graphics/libGL/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 73c785ed956a..dd6cc33f96f5 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -19,7 +19,8 @@ SUB_FILES= pkg-install pkg-deinstall
.include <bsd.port.options.mk>
.if defined(WITH_NEW_XORG)
-LIBGLREVISION= 0
+LIBGLREVISION= 1
+LIB_DEPENDS+= libglapi.so:${PORTSDIR}/graphics/libglapi
.else
LIBGLREVISION= 4
.endif
@@ -30,11 +31,18 @@ LIBGLREVISION= 4
CONFIGURE_ARGS+=--disable-gallium-intel
.endif
-.if !defined(WITH_NEW_XORG)
post-install:
+.if defined(WITH_NEW_XORG)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/.libGL
+ @${MV} ${STAGEDIR}${PREFIX}/lib/libGL* \
+ ${STAGEDIR}${PREFIX}/lib/.libGL/
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libglapi*
+ ${RM} -f ${STAGEDIR}${PREFIX}/libdata/pkgconfig/dri.pc
+ ${RM} -rf ${STAGEDIR}${PREFIX}/include/GL/internal
+.else
${RM} ${STAGEDIR}${PREFIX}/include/GL/glu.h
${RM} ${STAGEDIR}${PREFIX}/include/GL/glu_mangle.h
- ${RM} ${STAGEDIR}${PREFIX}/include/GL/internal/dri_interface.h
+ ${RM} -rf ${STAGEDIR}${PREFIX}/include/GL/internal
${RM} ${STAGEDIR}${PREFIX}/libdata/pkgconfig/dri.pc
.endif