aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libGL
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2010-02-07 19:51:08 +0800
committernork <nork@FreeBSD.org>2010-02-07 19:51:08 +0800
commitb85d81300d9cfcf809c18e54b11f18ff4164589f (patch)
tree1f7306b9776d87799a858bc92fdcb076f4ee8110 /graphics/libGL
parent43c7cc7f7b34ef550c5ab06d62a09a429357deff (diff)
downloadfreebsd-ports-gnome-b85d81300d9cfcf809c18e54b11f18ff4164589f.tar.gz
freebsd-ports-gnome-b85d81300d9cfcf809c18e54b11f18ff4164589f.tar.zst
freebsd-ports-gnome-b85d81300d9cfcf809c18e54b11f18ff4164589f.zip
Limited Update to Mesa3D 7.6.1 and libdrm 2.4.17.
[MEMO] In this commit, no version changed. But if you put 'WITHOUT_NOUVEAU' on /etc/make.conf, you can use new version of Mesa3D and libdrm. Discussed with: rnoland on freebsd-ports/freebsd-x11.
Diffstat (limited to 'graphics/libGL')
-rw-r--r--graphics/libGL/Makefile4
-rw-r--r--graphics/libGL/bsd.mesalib.mk47
-rw-r--r--graphics/libGL/distinfo3
-rw-r--r--graphics/libGL/files/mesalib74-configure (renamed from graphics/libGL/files/patch-configure)0
-rw-r--r--graphics/libGL/pkg-plist5
5 files changed, 39 insertions, 20 deletions
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index b3bbb25c04cd..24f8e4892bbb 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -17,6 +17,10 @@ LIB_DEPENDS+= drm:${PORTSDIR}/graphics/libdrm \
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto:both
+.ifdef WITH_NOUVEAU
+EXTRA_PATCHES= mesalib74-configure
+.endif
+
do-install:
${RM} ${WRKSRC}/include/GL/glu*.h
cd ${WRKSRC}/src/mesa; ${GMAKE} install-libgl
diff --git a/graphics/libGL/bsd.mesalib.mk b/graphics/libGL/bsd.mesalib.mk
index a3e95cde64d9..acf8594290e9 100644
--- a/graphics/libGL/bsd.mesalib.mk
+++ b/graphics/libGL/bsd.mesalib.mk
@@ -12,37 +12,50 @@
# - graphics/libGL
# - graphics/libGLU
# - graphics/libGLw
+# - graphics/libglut
# - graphics/dri
#
# $FreeBSD$
#
-MESAVERSION= 7.4.4
-MASTER_SITES?= SF/mesa3d/MesaLib/${PORTVERSION}:mesa \
- ftp://ftp.fu-berlin.de/pub/unix/X11/graphics/Mesa/:mesa,glut,demos
+MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
+MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
+
+.ifdef WITHOUT_NOUVEAU
+MESABASEVERSION= 7.6.1
+MESASUBVERSION=
+PLIST_SUB+= MESALIB76= MESALIB74="@comment "
+.else
+MESABASEVERSION= 7.4.4
+MESASUBVERSION=
+PLIST_SUB+= MESALIB74= MESALIB76="@comment "
+.endif
+
+MASTER_SITES?= ftp://ftp.freedesktop.org/pub/mesa/${MESABASEVERSION}/:mesa,glut,demos
MASTER_SITE_SUBDIR= mesa3d
-DISTFILES= MesaLib-${MESAVERSION}${EXTRACT_SUFX}:mesa
+DISTFILES= MesaLib-${MESADISTVERSION}${EXTRACT_SUFX}:mesa
MAINTAINER?= x11@FreeBSD.org
-USE_BZIP2= yes
-USE_GMAKE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
- LDFLAGS=-L${LOCALBASE}/lib
+ LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-gallium
-ALL_TARGET= default
+ALL_TARGET= default
-#MAKE_ARGS= SHELL=${SH}
-#CFLAGS+= -DUSE_XSHM -DHZ=100
+#MAKE_ARGS= SHELL=${SH}
+#CFLAGS+= -DUSE_XSHM -DHZ=100
-#FILESDIR= ${.CURDIR}/../../graphics/libGL/files
-WRKSRC= ${WRKDIR}/Mesa-${MESAVERSION}
+#FILESDIR= ${.CURDIR}/../../graphics/libGL/files
+WRKSRC= ${WRKDIR}/Mesa-${MESABASEVERSION}
.if !defined(ARCH)
-ARCH!= uname -p
+ARCH!= uname -p
.endif
.if ${ARCH} == alpha
@@ -51,7 +64,7 @@ FAST_MATH=
FAST_MATH= -ffast-math
.endif
-COMPONENT= ${PORTNAME:L:C/^lib//:C/mesa-//}
+COMPONENT= ${PORTNAME:L:C/^lib//:C/mesa-//}
.if ${COMPONENT:Mglut} == ""
. if ${COMPONENT:Mglu} == ""
@@ -60,8 +73,7 @@ CONFIGURE_ARGS+= --disable-glu --disable-glut
CONFIGURE_ARGS+= --disable-glut
. endif
.else
-MASTER_SITES+= SF/mesa3d/MesaGLUT/${MESAVERSION}:glut
-DISTFILES+= MesaGLUT-${MESAVERSION}${EXTRACT_SUFX}:glut
+DISTFILES+= MesaGLUT-${MESADISTVERSION}${EXTRACT_SUFX}:glut
.endif
.if ${COMPONENT:Mglw} == ""
@@ -73,8 +85,7 @@ CONFIGURE_ARGS+= --enable-motif
.if ${COMPONENT:Mdemos} == ""
CONFIGURE_ARGS+= --with-demos=no
.else
-MASTER_SITES+= SF/mesa3d/MesaDemos/${MESAVERSION}:demos
-DISTFILES+= MesaDemos-${MESAVERSION}${EXTRACT_SUFX}:demos
+DISTFILES+= MesaDemos-${MESADISTVERSION}${EXTRACT_SUFX}:demos
CONFIGURE_ARGS+= --with-demos=demos,xdemos
.endif
diff --git a/graphics/libGL/distinfo b/graphics/libGL/distinfo
index 0e8176eee482..b44fb336d3ad 100644
--- a/graphics/libGL/distinfo
+++ b/graphics/libGL/distinfo
@@ -1,3 +1,6 @@
MD5 (MesaLib-7.4.4.tar.bz2) = b66528d314c574dccbe0ed963cac5e93
SHA256 (MesaLib-7.4.4.tar.bz2) = eaf73d7a3a2dc959ddc0753abaa18160c64bec00b35bf4a0c96040b2072918ec
SIZE (MesaLib-7.4.4.tar.bz2) = 3375615
+MD5 (MesaLib-7.6.1.tar.bz2) = 7db4617e9e10ad3aca1b64339fd71b7d
+SHA256 (MesaLib-7.6.1.tar.bz2) = 701f0e4cb85d6298181651b780d1c0a439fadd02aad29ee6623fc05588bb8d44
+SIZE (MesaLib-7.6.1.tar.bz2) = 4886995
diff --git a/graphics/libGL/files/patch-configure b/graphics/libGL/files/mesalib74-configure
index af45b71f21c3..af45b71f21c3 100644
--- a/graphics/libGL/files/patch-configure
+++ b/graphics/libGL/files/mesalib74-configure
diff --git a/graphics/libGL/pkg-plist b/graphics/libGL/pkg-plist
index a63eaaa78a06..b07eac0fa6cd 100644
--- a/graphics/libGL/pkg-plist
+++ b/graphics/libGL/pkg-plist
@@ -1,17 +1,18 @@
include/GL/dmesa.h
include/GL/ggimesa.h
-include/GL/gl_mangle.h
include/GL/gl.h
+include/GL/gl_mangle.h
include/GL/glext.h
include/GL/glfbdev.h
-include/GL/glx_mangle.h
include/GL/glx.h
+include/GL/glx_mangle.h
include/GL/glxext.h
include/GL/mesa_wgl.h
include/GL/mglmesa.h
include/GL/osmesa.h
include/GL/svgamesa.h
include/GL/vms_x_fix.h
+%%MESALIB76%%include/GL/wglext.h
include/GL/wmesa.h
lib/libGL.so
lib/libGL.so.1