aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libflash/files
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-10-14 17:28:52 +0800
committerknu <knu@FreeBSD.org>2000-10-14 17:28:52 +0800
commit749c8f9fd563518e25523dbce8dc7d493d77878a (patch)
tree0f2d7bc26eef3864aa9b447abb69352bfc907844 /graphics/libflash/files
parent09d430de664c2f6cdcff081f9ee9073937436495 (diff)
downloadfreebsd-ports-gnome-749c8f9fd563518e25523dbce8dc7d493d77878a.tar.gz
freebsd-ports-gnome-749c8f9fd563518e25523dbce8dc7d493d77878a.tar.zst
freebsd-ports-gnome-749c8f9fd563518e25523dbce8dc7d493d77878a.zip
Separate libflash from flashplayer after a repocopy.
libflash (FlashLib) is a GPL Flash (TM) Library to play Flash movies.
Diffstat (limited to 'graphics/libflash/files')
-rw-r--r--graphics/libflash/files/Makefile21
-rw-r--r--graphics/libflash/files/patch-ah35
-rw-r--r--graphics/libflash/files/patch-ai14
3 files changed, 54 insertions, 16 deletions
diff --git a/graphics/libflash/files/Makefile b/graphics/libflash/files/Makefile
new file mode 100644
index 000000000000..7d6b4df5eb29
--- /dev/null
+++ b/graphics/libflash/files/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+LIB= flash
+SHLIB_MAJOR?= 0
+SHLIB_MINOR?= 4
+CXXFLAGS+= -fno-rtti -DXP_UNIX \
+ -I${LOCALBASE}/include \
+ -DCHECK_TEXT_PLAIN
+LDADD= -lz \
+ -L${LOCALBASE}/lib -ljpeg
+SRCS= adpcm.cc bitmap.cc button.cc character.cc cxform.cc \
+ displaylist.cc flash.cc font.cc graphic.cc graphic16.cc \
+ graphic24.cc graphic32.cc matrix.cc movie.cc \
+ program.cc script.cc shape.cc sound.cc \
+ sprite.cc sqrt.cc text.cc
+INCS= flash.h
+NOMAN= YES
+LIBDIR= ${LOCALBASE}/lib
+INCDIR= ${LOCALBASE}/include
+
+.include <bsd.lib.mk>
diff --git a/graphics/libflash/files/patch-ah b/graphics/libflash/files/patch-ah
index da5fa199155b..80628391a448 100644
--- a/graphics/libflash/files/patch-ah
+++ b/graphics/libflash/files/patch-ah
@@ -1,21 +1,24 @@
---- Lib/cxform.cc.orig Sun Aug 6 18:07:51 2000
-+++ Lib/cxform.cc Sun Aug 6 18:08:18 2000
-@@ -23,7 +23,7 @@
+--- cxform.cc.orig Tue May 2 04:18:33 2000
++++ cxform.cc Thu Oct 12 14:44:03 2000
+@@ -26,6 +26,10 @@
static char *rcsid = "$Id";
-
- #ifdef __FreeBSD__
--#include <floatingpoint.h>
-+#include <ieeefp.h>
#endif
- #include "cxform.h"
-@@ -63,7 +63,9 @@
- if (newColor.blue > 255) newColor.blue = 255;
- newColor.alpha = getAlpha(color.alpha);
- #ifdef __FreeBSD__
-+#ifndef __alpha__
- fpresetsticky(FP_X_DZ|FP_X_INV);
++#ifdef __FreeBSD__
++#include <ieeefp.h>
++#endif
++
+ long
+ Cxform::getRed(long v) {
+ long val;
+@@ -69,6 +73,10 @@
+ Color
+ Cxform::getColor(Color color) {
+ Color newColor;
++
++#ifdef __FreeBSD__
++ fpsetmask(0);
+#endif
- fpsetmask(FP_X_DZ|FP_X_INV);
- #endif
+ newColor.red = getRed(color.red);
+ newColor.green = getGreen(color.green);
diff --git a/graphics/libflash/files/patch-ai b/graphics/libflash/files/patch-ai
new file mode 100644
index 000000000000..d9dd605804b7
--- /dev/null
+++ b/graphics/libflash/files/patch-ai
@@ -0,0 +1,14 @@
+--- sound.cc.orig Thu Sep 2 00:10:03 1999
++++ sound.cc Thu Oct 12 14:49:31 2000
+@@ -26,7 +26,11 @@
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+ #ifndef NOSOUND
++#ifdef __FreeBSD__
++#include <machine/soundcard.h>
++#else
+ #include <linux/soundcard.h>
++#endif
+ #endif
+
+ #ifdef RCSID