aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libfpx/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-11 04:35:18 +0800
committerwill <will@FreeBSD.org>2001-03-11 04:35:18 +0800
commit7b375bddfa5f700598340be49c5650f7747ea15f (patch)
tree847186b747c14c82c298d58c0c61eaa4dd99a41e /graphics/libfpx/Makefile
parent1cb6118c244d15157ec22051384a3555a24d5989 (diff)
downloadfreebsd-ports-gnome-7b375bddfa5f700598340be49c5650f7747ea15f.tar.gz
freebsd-ports-gnome-7b375bddfa5f700598340be49c5650f7747ea15f.tar.zst
freebsd-ports-gnome-7b375bddfa5f700598340be49c5650f7747ea15f.zip
Add libfpx 1.2.0, library routines for working with Flashpix images.
PR: 24313 Submitted by: mi
Diffstat (limited to 'graphics/libfpx/Makefile')
-rw-r--r--graphics/libfpx/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
new file mode 100644
index 000000000000..470bff4f352e
--- /dev/null
+++ b/graphics/libfpx/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fpx
+# Date created: Jan 10 2001
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpx
+PORTVERSION= 1.2.0
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.wizards.dupont.com/pub/%SUBDIR%/ \
+ ftp://ftp.u-aizu.ac.jp/pub/graphics/image/%SUBDIR%/ \
+ ftp://ftp.fifi.org/pub/%SUBDIR%/ \
+ ftp://gd.tuwien.ac.at/pub/graphics/%SUBDIR%/ \
+ ftp://ftp.ms.mff.cuni.cz/MIRRORS/ftp.wizards.dupont.com/pub/%SUBDIR%/ \
+ ftp://ftp.oce.nl/pub/Internet/audio+video/%SUBDIR%/
+MASTER_SITE_SUBDIR= ImageMagick/delegates
+
+MAINTAINER= mi@aldan.algebra.com
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+WRKSRC= ${WRKDIR}/lib${DISTNAME}
+
+post-patch:
+ # Replacing references to <malloc.h> with <stdlib.h>
+ # Ignore the /dev/stderr warning below. (What a hack!)
+ ${PERL} -pi -e 's/<malloc.h>/<stdlib.h>/' \
+ `find ${WRKSRC} -type f | xargs ${GREP} -l '<malloc.h>'` /dev/stderr
+
+INSTALLS_SHLIB= yes
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+.include <bsd.port.mk>