aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libfpx
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-12-23 04:12:06 +0800
committermi <mi@FreeBSD.org>2001-12-23 04:12:06 +0800
commit5da9d2a547e65a47b77be118308e3cc2e971a06b (patch)
treed92fe110bdf3c9b25bb54ea6635c0aaf0cb09bec /graphics/libfpx
parentb9c2fd16f517f30d9c6df4ed1f01fb2e1cb4d894 (diff)
downloadfreebsd-ports-gnome-5da9d2a547e65a47b77be118308e3cc2e971a06b.tar.gz
freebsd-ports-gnome-5da9d2a547e65a47b77be118308e3cc2e971a06b.tar.zst
freebsd-ports-gnome-5da9d2a547e65a47b77be118308e3cc2e971a06b.zip
Reorder the include (-I) path to end, rather than start, with
${LOCALBASE}/include. The old behaviour was working almost always, because the package's own header files are well-named, except for the common.h, which caused build failure for at least one person. PR: ports/32247
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/files/Makefile.bsd3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index 92fa703a2fc1..f425028c0924 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -22,7 +22,6 @@ CPPS += ${OLESS:S/^/${.CURDIR}\/oless\//} ${JPGS}
SRCS = ${CPPS:T}
-CXXFLAGS+= -I${LOCALBASE}/include -D_UNIX
CXXFLAGS+= -fno-rtti -fno-exceptions
LDADD += -L${LOCALBASE}/lib -ljpeg
@@ -32,4 +31,6 @@ LDADD += -L${LOCALBASE}/lib -ljpeg
CXXFLAGS+= -I${.CURDIR}/$d
.endfor
+CXXFLAGS+= -I${LOCALBASE}/include -D_UNIX
+
.include <bsd.lib.mk>