aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libglesv2
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-10-17 17:53:13 +0800
committerkwm <kwm@FreeBSD.org>2014-10-17 17:53:13 +0800
commitd6afb37e19f66eed665826275fba54cca09a8c89 (patch)
tree10eadf882ac174da154c3fda250d8872d4fa1acc /graphics/libglesv2
parent4bc9e1fc7d12f2e377422acc4d926720bde09698 (diff)
downloadfreebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.tar.gz
freebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.tar.zst
freebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.zip
Update Mesa ports to new default of 9.1.7 and more recent version to 10.3.0.
The port will switch to the newer version if hw context is available in the i915kms driver. - Get ride of WITH_NEW_XORG. - Use @comment in plist to ignore unwanted files in the stagedir, instead of trying to remove them in post-install. - Bump portrevision of 9.1.7 due to dependency changes. - Drop :keepla from USES=libtool. - Drop @dirrm[try] from plists - Give dri propper options, with pkg-help for additional information. - Make separate plist for dri for the different versions, the combined plist was headache inducing. - Add "workaround" patches to allow clang to build the dri port on i386 [1]. USE_GCC is now only needed for 8.x. - Add gbm port and USE_GL switch for it. PR: 192286 [1] Submitted by: Carlos Jacobo Puga Medina [1] Approved by: portmgr (bapt@) In collaberation with: dumbbell@ Obtained from: xorg-dev
Diffstat (limited to 'graphics/libglesv2')
-rw-r--r--graphics/libglesv2/Makefile39
-rw-r--r--graphics/libglesv2/pkg-plist4
2 files changed, 26 insertions, 17 deletions
diff --git a/graphics/libglesv2/Makefile b/graphics/libglesv2/Makefile
index 371e0d445db1..5f74dbf2144e 100644
--- a/graphics/libglesv2/Makefile
+++ b/graphics/libglesv2/Makefile
@@ -3,31 +3,42 @@
PORTNAME= libglesv2
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
+PORTREVISION= ${LIBGLES_REVISION}
CATEGORIES= graphics
COMMENT= OpenGL ES v2 library
-BUILD_DEPENDS= expat>=0:${PORTSDIR}/textproc/expat2
LIB_DEPENDS+= libdrm.so:${PORTSDIR}/graphics/libdrm \
- libglapi.so:${PORTSDIR}/graphics/libglapi
+ libglapi.so:${PORTSDIR}/graphics/libglapi \
+ libexpat.so:${PORTSDIR}/textproc/expat2
+
+# stuff not needed by libglesv2 but configure wants it
+USE_XORG+= glproto dri2proto xext xdamage xfixes presentproto \
+ xshmfence
.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
-.if ! defined(WITH_NEW_XORG)
-IGNORE= Please enable WITH_NEW_XORG, libglesv2 needs libdrm higher then 2.4.24
+.if defined(WITH_NEW_MESA)
+LIBGLES_REVISION= 0
+.else
+LIBGLES_REVISION= 3
.endif
-# stuff not needed by libEGL but configure wants it
-USE_XORG+= glproto dri2proto xext xdamage xfixes
-
-
-BUILD_WKRSRC= ${WRKSRC}/src/mapi/es2api
+.if defined(WITH_NEW_MESA)
+BUILD_WRKSRC= ${WRKSRC}/src/mapi
+INSTALL_WRKSRC= ${WRKSRC}/src/mapi
+.else
+BUILD_WRKSRC= ${WRKSRC}/src/mapi/es2api
INSTALL_WRKSRC= ${WRKSRC}/src/mapi/es2api
+.endif
-# this library doesn't exist in Mesa 7.6 so use newer
-WITH_NEW_XORG=yes
+.if !defined(WITH_NEW_MESA)
+pre-build:
+ @cd ${WRKSRC}/src/mapi/shared-glapi && ${MAKE_CMD} ${_MAKE_JOBS}
+.else
+post-install:
+ @${RM} ${STAGEDIR}/${PREFIX}/lib/libglapi*
+.endif
-.include <bsd.port.options.mk>
-.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
.include <bsd.port.mk>
diff --git a/graphics/libglesv2/pkg-plist b/graphics/libglesv2/pkg-plist
index 45c4e97a929e..3c7cb53d2282 100644
--- a/graphics/libglesv2/pkg-plist
+++ b/graphics/libglesv2/pkg-plist
@@ -2,12 +2,10 @@ include/GLES2/gl2.h
include/GLES2/gl2ext.h
include/GLES2/gl2platform.h
include/GLES3/gl3.h
+%%NEW%%include/GLES3/gl31.h
include/GLES3/gl3ext.h
include/GLES3/gl3platform.h
-lib/libGLESv2.la
lib/libGLESv2.so
lib/libGLESv2.so.2
lib/libGLESv2.so.2.0.0
libdata/pkgconfig/glesv2.pc
-@dirrmtry include/GLES3
-@dirrmtry include/GLES2