aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libosmesa/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-04-12 15:57:35 +0800
committerpav <pav@FreeBSD.org>2011-04-12 15:57:35 +0800
commit77e23b0f8f2187eb5d44dcfa00da82e5bf690e5c (patch)
tree339c6492407b1a425cae874744b34c8de753e712 /graphics/libosmesa/Makefile
parent8c22d3794af2a236a392f1e3e42b1a8f90555ffd (diff)
downloadfreebsd-ports-gnome-77e23b0f8f2187eb5d44dcfa00da82e5bf690e5c.tar.gz
freebsd-ports-gnome-77e23b0f8f2187eb5d44dcfa00da82e5bf690e5c.tar.zst
freebsd-ports-gnome-77e23b0f8f2187eb5d44dcfa00da82e5bf690e5c.zip
- Mark BROKEN on 9.X: does not install
Reported by: pointyhat
Diffstat (limited to 'graphics/libosmesa/Makefile')
-rw-r--r--graphics/libosmesa/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 3d30396bc5ef..afbde6af07ec 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -39,6 +39,12 @@ GLINC= gl.h glext.h osmesa.h
GLLIB= OSMesa32
SHLIB_VERS= ${PORTVERSION:R:R}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+BROKEN= does not install on 9.X
+.endif
+
do-install:
${MKDIR} ${PREFIX}/include/Mesa/GL
${MKDIR} ${PREFIX}/lib
@@ -56,4 +62,4 @@ do-install:
cd ${WRKSRC}/src/mesa && ${GMAKE} osmesa.pc
${INSTALL_DATA} ${WRKSRC}/src/mesa/osmesa.pc ${PREFIX}/libdata/pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>