aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libqglviewer
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-06-14 09:58:13 +0800
committerijliao <ijliao@FreeBSD.org>2004-06-14 09:58:13 +0800
commitefcf28e5355cfc42ff3b636475540d0049e00472 (patch)
tree23acdba4e1e4cd28df41309613e49377c0985beb /graphics/libqglviewer
parentfae4e33909d22127cf6426adaac25f0acefb8055 (diff)
downloadfreebsd-ports-gnome-efcf28e5355cfc42ff3b636475540d0049e00472.tar.gz
freebsd-ports-gnome-efcf28e5355cfc42ff3b636475540d0049e00472.tar.zst
freebsd-ports-gnome-efcf28e5355cfc42ff3b636475540d0049e00472.zip
add missing dependent
mark broken on 4.x Noticed by: bento via kris
Diffstat (limited to 'graphics/libqglviewer')
-rw-r--r--graphics/libqglviewer/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/libqglviewer/Makefile b/graphics/libqglviewer/Makefile
index be9e2e939b9d..a087c9fc4a7e 100644
--- a/graphics/libqglviewer/Makefile
+++ b/graphics/libqglviewer/Makefile
@@ -15,6 +15,8 @@ DISTNAME= libQGLViewer-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library helps development of 3D applications
+BUILD_DEPENDS= ${QMAKE}:${PORTSDIR}/devel/qmake
+
USE_BZIP2= yes
USE_QT_VER= 3
MAKE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
@@ -25,6 +27,12 @@ INSTALLS_SHLIB= yes
DOCSDIR= ${PREFIX}/share/doc/QGLViewer
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
do-build:
@(cd ${WRKSRC}/QGLViewer && ${SETENV} ${MAKE_ENV} ${QMAKE} && \
${SETENV} ${MAKE_ENV} ${MAKE})
@@ -38,4 +46,4 @@ post-install:
@${FIND} ${PREFIX}/include/QGLViewer -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>