aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/librsvg/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2001-05-09 02:57:01 +0800
committerade <ade@FreeBSD.org>2001-05-09 02:57:01 +0800
commit3c244fc7368bde14c918e37f2eb3daf813f4f0a6 (patch)
tree7002be77c212ecd6cc3d813be8a30851e24562f4 /graphics/librsvg/Makefile
parent52948ac5f3ffa09c30677ef93749340d47eccde4 (diff)
downloadfreebsd-ports-gnome-3c244fc7368bde14c918e37f2eb3daf813f4f0a6.tar.gz
freebsd-ports-gnome-3c244fc7368bde14c918e37f2eb3daf813f4f0a6.tar.zst
freebsd-ports-gnome-3c244fc7368bde14c918e37f2eb3daf813f4f0a6.zip
The librsvg library is a lightweight library for parsing and rendering
vector-graphic files in SVG format (like the ones made by sodipodi). It also includes functions that render anti-aliased fonts using freetype, including caching of glyphs. It's used by Nautilus for drawing vector icons and anti-aliased type.
Diffstat (limited to 'graphics/librsvg/Makefile')
-rw-r--r--graphics/librsvg/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/librsvg/Makefile b/graphics/librsvg/Makefile
new file mode 100644
index 000000000000..c921e76dc539
--- /dev/null
+++ b/graphics/librsvg/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: librsvg
+# Date created: 8th May 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= librsvg
+PORTVERSION= 1.0.0
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= stable/sources/librsvg
+
+MAINTAINER= ade@FreeBSD.org
+
+BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
+LIB_DEPENDS= freetype.6:${PORTSDIR}/print/freetype2
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>