aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/librsvg2
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /graphics/librsvg2
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'graphics/librsvg2')
-rw-r--r--graphics/librsvg2/Makefile8
-rw-r--r--graphics/librsvg2/files/patch-moz-plugin_Makefile.in9
-rw-r--r--graphics/librsvg2/pkg-plist7
3 files changed, 11 insertions, 13 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index cb1d4f798781..df15602807d8 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -3,11 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/librsvg2/Makefile,v 1.121 2008/03/04 18:51:53 kwm Exp $
+# $MCom: ports-stable/graphics/librsvg2/Makefile,v 1.3 2008/09/23 20:34:45 mezz Exp $
#
PORTNAME= librsvg2
PORTVERSION= 2.22.3
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -46,7 +47,10 @@ OPTIONS= MOZILLA_PLUGIN "Enable the SVG browser plug-in" no
.if defined(WITH_MOZILLA_PLUGIN)
USE_GECKO= firefox mozilla seamonkey xulrunner
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=libmozsvgdec.so
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
CONFIGURE_ENV+= MOZILLA_CONFIG=no
CONFIGURE_ARGS+=--enable-mozilla-plugin=yes
@@ -61,6 +65,8 @@ post-patch:
.if defined(WITH_MOZILLA_PLUGIN)
@${REINPLACE_CMD} -e 's|mozilla-plugin|${GECKO}-plugin|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[$$][(]libdir[)]/mozilla/plugins|${WEBPLUGINS_DIR}|g' \
+ ${WRKSRC}/moz-plugin/Makefile.in
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/librsvg2/files/patch-moz-plugin_Makefile.in b/graphics/librsvg2/files/patch-moz-plugin_Makefile.in
index 93551c798bd0..728d20fcbd1c 100644
--- a/graphics/librsvg2/files/patch-moz-plugin_Makefile.in
+++ b/graphics/librsvg2/files/patch-moz-plugin_Makefile.in
@@ -1,14 +1,5 @@
--- moz-plugin/Makefile.in.orig 2008-09-23 15:17:45.000000000 -0500
+++ moz-plugin/Makefile.in 2008-09-23 15:19:11.000000000 -0500
-@@ -227,7 +227,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--plugindir = $(libdir)/mozilla/plugins
-+plugindir = $(libdir)/browser_plugins
- @WITH_MOZILLA_FALSE@plugin_LTLIBRARIES =
- @WITH_MOZILLA_TRUE@plugin_LTLIBRARIES = libmozsvgdec.la
- INCLUDES = $(MOZILLA_CFLAGS) -DBINDIR=\"$(bindir)/\" $(GLIB_CFLAGS) $(GDK_X11_CFLAGS)
@@ -270,7 +270,7 @@
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
install-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
diff --git a/graphics/librsvg2/pkg-plist b/graphics/librsvg2/pkg-plist
index e437b5ef6ca9..c89581974118 100644
--- a/graphics/librsvg2/pkg-plist
+++ b/graphics/librsvg2/pkg-plist
@@ -5,9 +5,9 @@ include/librsvg-2/librsvg/librsvg-enum-types.h
include/librsvg-2/librsvg/librsvg-features.h
include/librsvg-2/librsvg/rsvg-cairo.h
include/librsvg-2/librsvg/rsvg.h
-%%PLUGIN%%lib/browser_plugins/libmozsvgdec.a
-%%PLUGIN%%lib/browser_plugins/libmozsvgdec.la
-%%PLUGIN%%lib/browser_plugins/libmozsvgdec.so
+%%PLUGIN%%%%WEBPLUGINS_DIR%%/libmozsvgdec.a
+%%PLUGIN%%%%WEBPLUGINS_DIR%%/libmozsvgdec.la
+%%PLUGIN%%%%WEBPLUGINS_DIR%%/libmozsvgdec.so
lib/gtk-2.0/%%GTK2_VERSION%%/engines/libsvg.a
lib/gtk-2.0/%%GTK2_VERSION%%/engines/libsvg.la
lib/gtk-2.0/%%GTK2_VERSION%%/engines/libsvg.so
@@ -38,6 +38,7 @@ share/doc/rsvg/style.css
share/doc/rsvg/up.png
share/pixmaps/svg-viewer.svg
@dirrm share/doc/rsvg
+%%PLUGIN%%@dirrmtry %%WEBPLUGINS_DIR%%
@dirrm include/librsvg-2/librsvg
@dirrm include/librsvg-2
@exec %D/bin/gdk-pixbuf-query-loaders > /dev/null 2>&1 && %D/bin/gdk-pixbuf-query-loaders > %D/etc/gtk-2.0/gdk-pixbuf.loaders 2>/dev/null || /usr/bin/true