aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libspiro
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-13 00:16:57 +0800
committermiwi <miwi@FreeBSD.org>2008-01-13 00:16:57 +0800
commit3c5b39dbae29451b8fcff88951aad8419053041b (patch)
treed7db7f5cd4d17227c7f9f761ad60dbf9b47c49be /graphics/libspiro
parent6daca0f5d4d7bfaa2a43c6f2354456023b1d07f3 (diff)
downloadfreebsd-ports-gnome-3c5b39dbae29451b8fcff88951aad8419053041b.tar.gz
freebsd-ports-gnome-3c5b39dbae29451b8fcff88951aad8419053041b.tar.zst
freebsd-ports-gnome-3c5b39dbae29451b8fcff88951aad8419053041b.zip
Spiro is the creation of Raph Levien. It simplifies the drawing of beautiful
curves. Using bezier splines an artist can easily draw curves with the same slope on either side of an on-curve point. Spiros, on the other hand, are based on clothoid splines which make it easy to maintain constant curvature as well as constant slope. Such curves will simply look nicer. Raph Levien's spiro splines only use on-curve points and so are easier to use and more intuitive to the artist. This library will take an array of spiro control points and convert them into a series of bezier splines which can then be used in the myriad of ways the world has come to use beziers. WWW: http://libspiro.sourceforge.net/ PR: ports/119541 Submitted by: Naram Qashat <cyberbotx at cyberbotx.com>
Diffstat (limited to 'graphics/libspiro')
-rw-r--r--graphics/libspiro/Makefile24
-rw-r--r--graphics/libspiro/distinfo3
-rw-r--r--graphics/libspiro/pkg-descr21
-rw-r--r--graphics/libspiro/pkg-plist7
4 files changed, 55 insertions, 0 deletions
diff --git a/graphics/libspiro/Makefile b/graphics/libspiro/Makefile
new file mode 100644
index 000000000000..96a27cedaf5f
--- /dev/null
+++ b/graphics/libspiro/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libspiro
+# Date created: 10 Janurary 2008
+# Whom: Naram Qashat <cyberbotx@cyberbotx.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libspiro
+DISTVERSION= 20071029
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_src-${PORTVERSION}
+
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= Library to convert clothoid splines into bezier splines
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/libspiro/distinfo b/graphics/libspiro/distinfo
new file mode 100644
index 000000000000..a960257821a4
--- /dev/null
+++ b/graphics/libspiro/distinfo
@@ -0,0 +1,3 @@
+MD5 (libspiro_src-20071029.tar.bz2) = ab6aaa50bbd8fa55e78f8b8b0112f6cd
+SHA256 (libspiro_src-20071029.tar.bz2) = 1efeb1527bd48f8787281e8be1d0e8ff2e584d4c1994a0bc2f6859be2ffad4cf
+SIZE (libspiro_src-20071029.tar.bz2) = 172484
diff --git a/graphics/libspiro/pkg-descr b/graphics/libspiro/pkg-descr
new file mode 100644
index 000000000000..a6ffb49305bc
--- /dev/null
+++ b/graphics/libspiro/pkg-descr
@@ -0,0 +1,21 @@
+Spiro is the creation of Raph Levien. It simplifies the drawing of beautiful
+curves.
+
+Using bezier splines an artist can easily draw curves with the same slope on
+either side of an on-curve point. Spiros, on the other hand, are based on
+clothoid splines which make it easy to maintain constant curvature as well as
+constant slope. Such curves will simply look nicer.
+
+Raph Levien's spiro splines only use on-curve points and so are easier to use
+and more intuitive to the artist.
+
+This library will take an array of spiro control points and convert them into a
+series of bezier splines which can then be used in the myriad of ways the world
+has come to use beziers.
+
+(Above taken from Introduction on the library's website)
+
+WWW: http://libspiro.sourceforge.net/
+
+- Naram Qashat
+cyberbotx@cyberbotx.com
diff --git a/graphics/libspiro/pkg-plist b/graphics/libspiro/pkg-plist
new file mode 100644
index 000000000000..419a497f7e4c
--- /dev/null
+++ b/graphics/libspiro/pkg-plist
@@ -0,0 +1,7 @@
+include/bezctx.h
+include/bezctx_intf.h
+include/spiro.h
+include/spiroentrypoints.h
+lib/libspiro.la
+lib/libspiro.so
+lib/libspiro.so.0