aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libv3d
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/libv3d
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/libv3d')
-rw-r--r--graphics/libv3d/Makefile2
-rw-r--r--graphics/libv3d/files/patch-platforms.ini12
2 files changed, 7 insertions, 7 deletions
diff --git a/graphics/libv3d/Makefile b/graphics/libv3d/Makefile
index ada1e0dacc91..8edbc87d4803 100644
--- a/graphics/libv3d/Makefile
+++ b/graphics/libv3d/Makefile
@@ -81,7 +81,7 @@ MAN3= V3DGLInterpriteDelete.3 \
post-patch:
@${REINPLACE_CMD} -e "s,make,${GMAKE},g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s,%%CFLAGS%%,${CFLAGS},g" \
- -e "s,%%X11BASE%%,${X11BASE},g" \
+ -e "s,%%LOCALBASE%%,${LOCALBASE},g" \
-e "s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g" \
-e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g" \
${WRKSRC}/libv3d/platforms.ini
diff --git a/graphics/libv3d/files/patch-platforms.ini b/graphics/libv3d/files/patch-platforms.ini
index f6bbe8ae16d3..52c466df385c 100644
--- a/graphics/libv3d/files/patch-platforms.ini
+++ b/graphics/libv3d/files/patch-platforms.ini
@@ -13,17 +13,17 @@
CPP = c++
PlatformSearchPathInclude = /usr/include/
- PlatformSearchPathInclude = /usr/X11R6/include/
-+ PlatformSearchPathInclude = %%X11BASE%%/include/
++ PlatformSearchPathInclude = %%LOCALBASE%%/include/
PlatformSearchPathLib = /lib/
PlatformSearchPathLib = /usr/lib/
- PlatformSearchPathLib = /usr/X11R6/lib/
-+ PlatformSearchPathLib = %%X11BASE%%/lib/
++ PlatformSearchPathLib = %%LOCALBASE%%/lib/
PlatformSearchPathEtc = /etc/
PlatformSearchPathEtc = /usr/etc/
PlatformSearchPathBin = /bin/
PlatformSearchPathBin = /usr/bin/
- PlatformSearchPathBin = /usr/X11R6/bin/
-+ PlatformSearchPathBin = %%X11BASE%%/bin/
++ PlatformSearchPathBin = %%LOCALBASE%%/bin/
PlatformSearchPathBin = /usr/games/
PlatformSearchPathData = /usr/share/icons/
PlatformSearchPathData = /usr/share/games/
@@ -32,7 +32,7 @@
# FeatureCFLAGS =
# FeatureLIBS = -lSM -lICE -lX11 -lXext -lXi -lXmu
-# FeatureLIB_DIR = -L/usr/X11R6/lib/
-+# FeatureLIB_DIR = -L%%X11BASE%%/lib/
++# FeatureLIB_DIR = -L%%LOCALBASE%%/lib/
# FeatureDepend = X11-lib
# DependType = Library
# MustExist = Yes
@@ -42,9 +42,9 @@
MustExist = Yes
- FeatureLIBS = -lGL -lGLU
- FeatureLIB_DIR = -L/usr/X11R6/lib/
-+ FeatureCFLAGS = -I%%X11BASE%%/include %%PTHREAD_CFLAGS%% -fPIC
++ FeatureCFLAGS = -I%%LOCALBASE%%/include %%PTHREAD_CFLAGS%% -fPIC
+ FeatureLIBS = -lGL -lGLU %%PTHREAD_LIBS%%
-+ FeatureLIB_DIR = -L%%X11BASE%%/lib/
++ FeatureLIB_DIR = -L%%LOCALBASE%%/lib/
FeatureDepend = gl-lib
DependType = Library
MustExist = Yes