aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libvisual/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
committerade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
commit8d9d5197561118544281733430b48b0b60884450 (patch)
tree45e5dcd7c2206fce8b01186555aac96b6292c602 /graphics/libvisual/Makefile
parent081b17449bd91bcac5390cd0d8a63ed3914df51d (diff)
downloadfreebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.gz
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.zst
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'graphics/libvisual/Makefile')
-rw-r--r--graphics/libvisual/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/libvisual/Makefile b/graphics/libvisual/Makefile
index ce7820530c56..c8d61cb3f178 100644
--- a/graphics/libvisual/Makefile
+++ b/graphics/libvisual/Makefile
@@ -20,7 +20,7 @@ COMMENT= Abstraction library that sits between apps and visual plugin
USE_XLIBS= yes
USE_GNOME= gnomehack pkgconfig
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}