aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/linux-bmrt/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-02-08 20:19:57 +0800
committerkevlo <kevlo@FreeBSD.org>2001-02-08 20:19:57 +0800
commit9609625f9850da95adefc894dea8ba219106af1b (patch)
tree3843f5912ad18dea44cea8810b91fb740d97ef91 /graphics/linux-bmrt/Makefile
parent6d7915d18b694b4f0e47b27550b49a42d4c82659 (diff)
downloadfreebsd-ports-gnome-9609625f9850da95adefc894dea8ba219106af1b.tar.gz
freebsd-ports-gnome-9609625f9850da95adefc894dea8ba219106af1b.tar.zst
freebsd-ports-gnome-9609625f9850da95adefc894dea8ba219106af1b.zip
Update to version 2.6beta
PR: 24910 Submitted by: MAINTAINER
Diffstat (limited to 'graphics/linux-bmrt/Makefile')
-rw-r--r--graphics/linux-bmrt/Makefile42
1 files changed, 26 insertions, 16 deletions
diff --git a/graphics/linux-bmrt/Makefile b/graphics/linux-bmrt/Makefile
index 81c8c069d601..354fb86f1f6f 100644
--- a/graphics/linux-bmrt/Makefile
+++ b/graphics/linux-bmrt/Makefile
@@ -6,30 +6,40 @@
#
PORTNAME= linux-bmrt
-PORTVERSION= 2.5.0.8
+PORTVERSION= 2.6beta
CATEGORIES= graphics linux
-MASTER_SITES= http://www.bmrt.org/BMRTdownload/
-DISTNAME= BMRT2.5h.linux-glibc2
+MASTER_SITES= #fetch manually
+DISTNAME= BMRT${PORTVERSION}.linux-glibc2
MAINTAINER= rjoseph@mammalia.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
+RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base \
+ /compat/linux/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
-WRKSRC= ${WRKDIR}/BMRT2.5
+WRKSRC= ${WRKDIR}/BMRT2.6
NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
NO_CDROM= "See the License"
# Linux binary should not be stripped by INSTALL_PROGRAM as it uses
# /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
STRIP=
-# Linux binary should not be stripped by INSTALL_PROGRAM as it uses
-# /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
-STRIP=
+.include <bsd.port.pre.mk>
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= may not be automatically fetched due to licensing \
+ restrictions. You must manually fetch the Linux version at \
+ http://www.exluna.com/bmrt/download/index.html. \
+ Once you have read and agreed to the license and \
+ ${DISTFILES} has been downloaded, move it to \
+ ${DISTDIR} and then restart this build.
+.endif
+
+INC_DIR= ${PREFIX}/include/bmrt
+LIB_DIR= ${PREFIX}/lib/bmrt
DOC_DIR= ${PREFIX}/share/doc/bmrt
-FETCH_CMD= /usr/bin/fetch -Ab
-PROGRAM= composite mkmip mkmosaic rendrib rgl slc slctell
+PROGRAM= composite iv mkmip mkmosaic rendrib rgl slc slctell
SCRIPT= farm frankenrender
pre-install:
@@ -37,14 +47,17 @@ pre-install:
${SED} 's/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/' ${WRKSRC}/bin/frankenrender.old > ${WRKSRC}/bin/frankenrender
do-install:
- ${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/lib
+ ${MKDIR} ${LIB_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/lib/bmrt
${MKDIR} ${DOC_DIR}
${INSTALL_DATA} ${WRKSRC}/doc/bmrtdoc.pdf ${DOC_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/Changes ${DOC_DIR}
${INSTALL_DATA} ${WRKSRC}/License ${DOC_DIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOC_DIR}
${MKDIR} ${DOC_DIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOC_DIR}/html
- ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include
+ ${MKDIR} ${INC_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include/bmrt
${MKDIR} ${PREFIX}/share/examples/bmrt
${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/examples/bmrt
${MKDIR} ${PREFIX}/share/bmrt ${PREFIX}/share/bmrt/shaders
@@ -62,9 +75,6 @@ post-install:
@${ECHO} "";
@${ECHO} "************************************************************************";
@${ECHO} "";
- @${ECHO} " This is shareware that is free for non-commercial use.";
- @${ECHO} " Please read ${PREFIX}/share/doc/bmrt/License before proceeding.";
- @${ECHO} "";
@${ECHO} " Before using these programs, add the following";
@${ECHO} " path to your shell environment:";
@${ECHO} "";
@@ -80,4 +90,4 @@ post-install:
@${ECHO} "************************************************************************";
@${ECHO} "";
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>