aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/linux-f10-dri
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
committerxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
commitd39787ca07e42b7a91488f45cc6c58333ae10780 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /graphics/linux-f10-dri
parent143e62b0f3ebf9f9c709e4c068013418325fc64c (diff)
downloadfreebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.gz
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.zst
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Diffstat (limited to 'graphics/linux-f10-dri')
-rw-r--r--graphics/linux-f10-dri/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/graphics/linux-f10-dri/Makefile b/graphics/linux-f10-dri/Makefile
index 33d8c8c759eb..45cbc0dc3693 100644
--- a/graphics/linux-f10-dri/Makefile
+++ b/graphics/linux-f10-dri/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 7.2
PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-PKGNAMEPREFIX= linux-f10-
DISTFILES= Glide3-20050815-7.fc9.${LINUX_RPM_ARCH}.rpm \
freeglut-2.4.0-14.fc9.${LINUX_RPM_ARCH}.rpm \
libdrm-2.4.0-0.21.fc10.${LINUX_RPM_ARCH}.rpm \
@@ -14,24 +13,25 @@ DISTFILES= Glide3-20050815-7.fc9.${LINUX_RPM_ARCH}.rpm \
mesa-libGL-7.2-0.15.fc10.${LINUX_RPM_ARCH}.rpm \
mesa-libGLU-7.2-0.15.fc10.${LINUX_RPM_ARCH}.rpm
-.if defined(PACKAGE_BUILDING)
-SRC_DISTFILES= Glide3-20050815-7.fc9.src.rpm \
- freeglut-2.4.0-14.fc9.src.rpm \
- libdrm-2.4.0-0.21.fc10.src.rpm \
- mesa-7.2-0.15.fc10.src.rpm
-
-ALWAYS_KEEP_DISTFILES= YES
-.endif
-
MAINTAINER= emulation@FreeBSD.org
COMMENT= Mesa libGL runtime libraries and DRI drivers (Linux Fedora 10)
CONFLICTS= linux_dri-[0-9]* linux_dri-devel-[0-9]* linux-f8-dri-[0-9]* linux-dri-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= f10
USE_LINUX_RPM= yes
USE_LINUX_APPS= xorglibs
-LINUX_DIST_VER= 10
+
USE_LDCONFIG= yes
+.if defined(PACKAGE_BUILDING)
+SRC_DISTFILES= Glide3-20050815-7.fc9.src.rpm \
+ freeglut-2.4.0-14.fc9.src.rpm \
+ libdrm-2.4.0-0.21.fc10.src.rpm \
+ mesa-7.2-0.15.fc10.src.rpm
+
+ALWAYS_KEEP_DISTFILES= YES
+.endif
+
.include <bsd.port.mk>