aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/linux_glide
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-12-07 17:38:39 +0800
committerlinimon <linimon@FreeBSD.org>2007-12-07 17:38:39 +0800
commit31bc14738ef6ee3796591d1022d8ec5afda9b2eb (patch)
tree130660b3806f3fb3b507117cfa44670323202409 /graphics/linux_glide
parent99da7488462989a1a624a68612593dd1b352744e (diff)
downloadfreebsd-ports-gnome-31bc14738ef6ee3796591d1022d8ec5afda9b2eb.tar.gz
freebsd-ports-gnome-31bc14738ef6ee3796591d1022d8ec5afda9b2eb.tar.zst
freebsd-ports-gnome-31bc14738ef6ee3796591d1022d8ec5afda9b2eb.zip
Get rid of COPYTREE_SHARE, which should not be used for non-documentation,
and has bugs anyway, to fix deinstall. Discussed with: maintainer Tested on: pointyhat Approved by: portmgr (self)
Diffstat (limited to 'graphics/linux_glide')
-rw-r--r--graphics/linux_glide/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/linux_glide/Makefile b/graphics/linux_glide/Makefile
index 9f7eaccd0239..7113f352b66f 100644
--- a/graphics/linux_glide/Makefile
+++ b/graphics/linux_glide/Makefile
@@ -30,8 +30,8 @@ do-build:
(cd ${WRKSRC}; tar fx - lib include bin/test00)
do-install:
- (cd ${WRKSRC} && ${COPYTREE_SHARE} lib ${PREFIX}/usr)
- (cd ${WRKSRC} && ${COPYTREE_SHARE} include ${PREFIX}/usr)
+ (cd ${WRKSRC} && ${INSTALL_DATA} lib/* ${PREFIX}/usr/lib/)
+ (cd ${WRKSRC} && ${INSTALL_DATA} include/* ${PREFIX}/usr/include)
(cd ${WRKSRC} && ${INSTALL_PROGRAM} bin/test00 \
${PREFIX}/usr/bin/test-glide)
-/compat/linux/sbin/ldconfig