aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/makehuman
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-10 21:29:24 +0800
committermiwi <miwi@FreeBSD.org>2008-02-10 21:29:24 +0800
commitfa6f5c5008735b5c5927643bde405eb14bcddc66 (patch)
tree7c96b7612976d7c1f7dc25761aa2b8deffb7017a /graphics/makehuman
parent6af2c75299210aef7e569c13b077f2f734bf7207 (diff)
downloadfreebsd-ports-gnome-fa6f5c5008735b5c5927643bde405eb14bcddc66.tar.gz
freebsd-ports-gnome-fa6f5c5008735b5c5927643bde405eb14bcddc66.tar.zst
freebsd-ports-gnome-fa6f5c5008735b5c5927643bde405eb14bcddc66.zip
- Fix permissions handling under ${DATADIR}
- Bump PORTREVISION PR: 120327 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Diffstat (limited to 'graphics/makehuman')
-rw-r--r--graphics/makehuman/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/makehuman/Makefile b/graphics/makehuman/Makefile
index 3fe69d7a171a..3f396b95b50d 100644
--- a/graphics/makehuman/Makefile
+++ b/graphics/makehuman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= makehuman
DISTVERSION= 0.9.1-rc1a
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
@@ -40,4 +41,8 @@ post-patch:
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-makehumandocDATA||' ${WRKSRC}/Makefile.in
.endif
+post-install:
+ ${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 -n 10 ${CHMOD} 0755
+ ${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 -n 10 ${CHMOD} 0644
+
.include <bsd.port.mk>