aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mapserver
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2013-03-21 11:26:44 +0800
committerwen <wen@FreeBSD.org>2013-03-21 11:26:44 +0800
commitb2b0ee42d4cf05ede2d8b14168403ac4285cb561 (patch)
tree5805b8b0e68eba5056b5a179dc8ab7162d40f4e2 /graphics/mapserver
parent63952f5db7806ba70e37d4daef869de42044baf0 (diff)
downloadfreebsd-ports-gnome-b2b0ee42d4cf05ede2d8b14168403ac4285cb561.tar.gz
freebsd-ports-gnome-b2b0ee42d4cf05ede2d8b14168403ac4285cb561.tar.zst
freebsd-ports-gnome-b2b0ee42d4cf05ede2d8b14168403ac4285cb561.zip
- Add missing plist files
- Add option CAIRO and CAIRO_SVG Submitted by: Igor Zabelin <igorz@yandex.ru> (via Email)
Diffstat (limited to 'graphics/mapserver')
-rw-r--r--graphics/mapserver/Makefile27
-rw-r--r--graphics/mapserver/pkg-plist3
2 files changed, 27 insertions, 3 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 80730899604b..0c6cc545f402 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mapserver
PORTVERSION= 6.2.0
+PORTREVISION= 1
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
@@ -27,9 +28,10 @@ CONFIGURE_ARGS= --with-proj=${LOCALBASE} \
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= AGG TIFF PDF GDAL GEOS KML MING MYGIS POSTGIS PHP PERL PYTHON \
- WMS WFS MAPSERV FASTCGI DEBUG
+ WMS WFS MAPSERV FASTCGI DEBUG CAIRO CAIRO_SVG
OPTIONS_DEFAULT= AGG GDAL GEOS MAPSERV
AGG_DESC= AGG image rendering support
+CAIRO_SVG_DESC= Cairo SVG parser support
GDAL_DESC= GDAL library support
KML_DESC= KML support
MING_DESC= Macromedia Flash output support
@@ -60,7 +62,23 @@ PLIST_SUB+= PYTHON="@comment "
.if ${PORT_OPTIONS:MAGG}
LIB_DEPENDS+= agg:${PORTSDIR}/graphics/agg
-#CONFIGURE_ARGS+= --with-agg=${LOCALBASE} --with-freetype=${LOCALBASE}
+.endif
+
+.if ${PORT_OPTIONS:MCAIRO}
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo \
+ expat:${PORTSDIR}/textproc/expat2
+CONFIGURE_ARGS+= --with-cairo=yes --with-expat=${LOCALBASE}
+USE_PKGCONFIG= yes
+.endif
+
+.if ${PORT_OPTIONS:MCAIRO_SVG}
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo \
+ svg-cairo:${PORTSDIR}/graphics/libsvg-cairo \
+ expat:${PORTSDIR}/textproc/expat2
+CONFIGURE_ARGS+= --with-cairo=yes \
+ --with-libsvg-cairo \
+ --with-expat=${LOCALBASE}
+USE_PKGCONFIG= yes
.endif
.if ${PORT_OPTIONS:MKML}
@@ -151,7 +169,8 @@ CONFIGURE_ARGS+= --with-fastcgi=${LOCALBASE}
CONFIGURE_ARGS+= --enable-debug
.endif
-PROG_FILES= legend scalebar shp2img shptree shptreetst shptreevis sortshp
+PROG_FILES= legend scalebar shp2img shptree shptreetst shptreevis \
+ sortshp msencrypt tile4ms
post-patch:
.if ${PORT_OPTIONS:MMING}
@@ -168,6 +187,8 @@ do-install:
.for f in ${PROG_FILES}
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/libmapserver-6.2.0.so ${PREFIX}/lib
+
.if ${PORT_OPTIONS:MMAPSERV}
${MKDIR} ${LOCALBASE}/www/apache${APACHE_VERSION}/cgi-bin/
${INSTALL_SCRIPT} ${WRKSRC}/mapserv ${LOCALBASE}/www/apache${APACHE_VERSION}/cgi-bin/mapserv
diff --git a/graphics/mapserver/pkg-plist b/graphics/mapserver/pkg-plist
index 2328b7dd531a..62d384681833 100644
--- a/graphics/mapserver/pkg-plist
+++ b/graphics/mapserver/pkg-plist
@@ -1,10 +1,13 @@
bin/legend
+bin/msencrypt
bin/scalebar
bin/shp2img
bin/shptree
bin/shptreetst
bin/shptreevis
bin/sortshp
+bin/tile4ms
+lib/libmapserver-6.2.0.so
%%MAPSERV%%www/apache%%APA_VER%%/cgi-bin/mapserv
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/mapscript/mapscript.so
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/mapscript/mapscript.bs