aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mapyrus
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2015-02-03 06:56:46 +0800
committernivit <nivit@FreeBSD.org>2015-02-03 06:56:46 +0800
commit9d0c87214c7eaaafea6d76595f13804c9a9c7764 (patch)
tree80c145a13b958433b6e52717f7d11c74311f87ab /graphics/mapyrus
parentdd6fcca1d300b00503e58f9b683e1543c16c74ea (diff)
downloadfreebsd-ports-gnome-9d0c87214c7eaaafea6d76595f13804c9a9c7764.tar.gz
freebsd-ports-gnome-9d0c87214c7eaaafea6d76595f13804c9a9c7764.tar.zst
freebsd-ports-gnome-9d0c87214c7eaaafea6d76595f13804c9a9c7764.zip
- Update to 1.401
- Sort variables - Use COPYTREE_SHARE to install examples
Diffstat (limited to 'graphics/mapyrus')
-rw-r--r--graphics/mapyrus/Makefile31
-rw-r--r--graphics/mapyrus/distinfo4
-rw-r--r--graphics/mapyrus/files/mapyrus.in1
-rw-r--r--graphics/mapyrus/pkg-plist1
4 files changed, 18 insertions, 19 deletions
diff --git a/graphics/mapyrus/Makefile b/graphics/mapyrus/Makefile
index 69561af3956a..c21ac4e01ad6 100644
--- a/graphics/mapyrus/Makefile
+++ b/graphics/mapyrus/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= mapyrus
-PORTVERSION= 1.302
-PORTREVISION= 1
+PORTVERSION= 1.401
+PORTREVISION= 0
CATEGORIES= graphics print java
MASTER_SITES= SF
@@ -12,34 +12,33 @@ COMMENT= Software for creating plots of points, lines, etc
LICENSE= LGPL21
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
-USE_JAVA= yes
JAVA_VERSION= 1.6+
-USES= zip
-
-DATADIR= ${JAVASHAREDIR}/${PORTNAME}
-SUB_FILES= ${PORTNAME} pkg-message
-SUB_LIST= MAPYRUSJAR=${MAPYRUSJAR}
-MAPYRUSJAR= ${PORTNAME}.jar
MAPYRUSDOCS= ${PORTNAME}.pdf
+MAPYRUSJAR= ${PORTNAME}.jar
-FIND_DATA= -type f -not \( -iname "copying" -or -iname "*.tex" \)
-FIND_HERE= userdoc
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
+SUB_FILES= ${PORTNAME} pkg-message
+SUB_LIST= MAPYRUSJAR=${MAPYRUSJAR}
+
+USES= zip
+USE_JAVA= yes
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKDIR}/${MAPYRUSJAR} ${STAGEDIR}${DATADIR}/${MAPYRUSJAR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${MAPYRUSDOCS} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKDIR}/${MAPYRUSDOCS} ${STAGEDIR}${DOCSDIR}/${MAPYRUSDOCS}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKDIR} && ${FIND} ${FIND_HERE} ${FIND_DATA} -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR} \;
+ cd ${WRKDIR}/userdoc && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR} \
+ "-type f -not -iname copying -and -not -iname *\.tex"
.include <bsd.port.mk>
diff --git a/graphics/mapyrus/distinfo b/graphics/mapyrus/distinfo
index 31d8ea806120..eae3cd31bc3a 100644
--- a/graphics/mapyrus/distinfo
+++ b/graphics/mapyrus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mapyrus-1.302.zip) = 51414f6a8e5696dfe347a220612306958d9ad2e9ca8d2b284d0b5dc56521c614
-SIZE (mapyrus-1.302.zip) = 5113116
+SHA256 (mapyrus-1.401.zip) = 2781f2e0d9dee943976ffb28ead144542368de81e72bc54e78445c8aad94f7d1
+SIZE (mapyrus-1.401.zip) = 5116813
diff --git a/graphics/mapyrus/files/mapyrus.in b/graphics/mapyrus/files/mapyrus.in
index f8f8234c3a70..b9f54ed5ee69 100644
--- a/graphics/mapyrus/files/mapyrus.in
+++ b/graphics/mapyrus/files/mapyrus.in
@@ -1,5 +1,4 @@
#!/bin/sh
-# $FreeBSD$
if [ -z "${DISPLAY}" ]; then
JAVA_AWT_HEADLESS="-Djava.awt.headless=true"
else
diff --git a/graphics/mapyrus/pkg-plist b/graphics/mapyrus/pkg-plist
index 674a59cc5169..b153561a4626 100644
--- a/graphics/mapyrus/pkg-plist
+++ b/graphics/mapyrus/pkg-plist
@@ -57,6 +57,7 @@ bin/mapyrus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialfirst4.mapyrus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialflowlabel1.mapyrus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialflowlabel2.mapyrus
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialformatting1.mapyrus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialgeoimage1.mapyrus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialgeoimage2.mapyrus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorialgeoimage3.mapyrus