aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mesa-demos
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-04-22 01:03:32 +0800
committermiwi <miwi@FreeBSD.org>2012-04-22 01:03:32 +0800
commit8610de7ebcb688f7c822933cf96ecea22af9d9ac (patch)
tree58b95feaf2cd439308ad5db219bea76198f6e316 /graphics/mesa-demos
parent074f8111429b0ad96ac33c0e038ffb0e7ed50b11 (diff)
downloadfreebsd-ports-gnome-8610de7ebcb688f7c822933cf96ecea22af9d9ac.tar.gz
freebsd-ports-gnome-8610de7ebcb688f7c822933cf96ecea22af9d9ac.tar.zst
freebsd-ports-gnome-8610de7ebcb688f7c822933cf96ecea22af9d9ac.zip
- Please welcome Xorg 7.5.2
The Xorg Team is pleased to announce the next round of Xorg updates. The team created a new flag called WITH_NEW_XORG that users can include in /etc/make.conf. This was created for the intel KMS work being done althouthough It probably works for other chips. Unfortunately, the intel KMS driver will only work on FreeBSD 9(RELENG|STABLE) or 10/HEAD users. Older version of FreeBSD will not be supported. Intel users will need to patch their source manually with Konstantin?s KMS kernel patch to get the newer chips to work. Please carefully read UPDATING entry. Changes: - libdrm 2.4.31 (including KMS support) - mesa 7.11.2 - xorg-server 1.10.6 - a lot of new Graphic Drivers. I would like to thank: Koop Mast Eitan Adler Niclas Zeising and all helpers and testers from x11@.
Diffstat (limited to 'graphics/mesa-demos')
-rw-r--r--graphics/mesa-demos/Makefile48
-rw-r--r--graphics/mesa-demos/distinfo4
-rw-r--r--graphics/mesa-demos/files/config30
-rw-r--r--graphics/mesa-demos/files/patch-src__mesa__x86-64__glapi_x86-64.S12
-rw-r--r--graphics/mesa-demos/files/patch-src__mesa__x86-64__xform4.S74
-rw-r--r--graphics/mesa-demos/files/patch-src__mesa__x86__glapi_x86.S11
-rw-r--r--graphics/mesa-demos/files/patch-src__mesa__x86__read_rgba_span_x86.S11
-rw-r--r--graphics/mesa-demos/pkg-plist17
8 files changed, 153 insertions, 54 deletions
diff --git a/graphics/mesa-demos/Makefile b/graphics/mesa-demos/Makefile
index f950531a3f72..1bceb961108a 100644
--- a/graphics/mesa-demos/Makefile
+++ b/graphics/mesa-demos/Makefile
@@ -5,25 +5,54 @@
# $FreeBSD$
#
-PORTNAME= demos
-PORTVERSION= ${MESAVERSION}
+PORTNAME= mesa-demos
+PORTVERSION= 7.6.1
CATEGORIES= graphics
-MASTER_SITES= CRITICAL/mesa3d:mesa,glut,demos
-PKGNAMEPREFIX= mesa-
+MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${PORTVERSION}/
+DISTFILES= MesaLib-${PORTVERSION}${EXTRACT_SUFX} \
+ MesaDemos-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL demos distributed with Mesa
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
USE_GL= glu glut
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --disable-gallium --with-demos=demos,xdemos
+
+#ALL_TARGET= yes
+
+WRKSRC= ${WRKDIR}/Mesa-${PORTVERSION}/
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
OPTIONS= NVIDIA_GL "Use NVIDIA's libraries" off
-EXTRA_PATCHES+= ${FILESDIR}/patch-progs-xdemos-glxpixmap.c \
- ${FILESDIR}/patch-progs-xdemos-yuvrect_client.c
+.if defined(WITHOUT_XCB)
+CONFIGURE_ARGS+= --disable-xcb
+.else
+CONFIGURE_ARGS+= --enable-xcb
+.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ffast-math|${FAST_MATH}|' -e 's|x86_64|amd64|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[$$](INSTALL_LIB_DIR)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/src/glu/Makefile \
+ ${WRKSRC}/src/glw/Makefile \
+ ${WRKSRC}/src/mesa/Makefile \
+ ${WRKSRC}/src/mesa/drivers/dri/Makefile
+ @${REINPLACE_CMD} -e 's|../images/|${DATADIR}/images/|g' \
+ -e 's|geartrain.dat|${DATADIR}/data/geartrain.dat|g' \
+ -e 's|terrain.dat|${DATADIR}/data/terrain.dat|g' \
+ -e 's|isosurf.dat|${DATADIR}/data/isosurf.dat|g' \
+ ${WRKSRC}/progs/demos/*.c ${WRKSRC}/progs/xdemos/*.c
do-install:
@for i in demos xdemos; do \
@@ -45,13 +74,14 @@ do-install:
${INSTALL_DATA} $$i ${DATADIR}/data; \
done
-.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
.include <bsd.port.pre.mk>
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
.if defined(WITH_NVIDIA_GL)
CFLAGS+= -DWITH_NVIDIA_GL=1
.endif
+.if !defined(ARCH)
+ARCH!= uname -p
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/mesa-demos/distinfo b/graphics/mesa-demos/distinfo
index 379a40cf7bcd..738047a00e75 100644
--- a/graphics/mesa-demos/distinfo
+++ b/graphics/mesa-demos/distinfo
@@ -1,7 +1,3 @@
-SHA256 (MesaLib-7.4.4.tar.bz2) = eaf73d7a3a2dc959ddc0753abaa18160c64bec00b35bf4a0c96040b2072918ec
-SIZE (MesaLib-7.4.4.tar.bz2) = 3375615
-SHA256 (MesaDemos-7.4.4.tar.bz2) = 2b055f1b364795caec122092dedca9ac3ecce4fcf61947f52a286a681e9d1111
-SIZE (MesaDemos-7.4.4.tar.bz2) = 1367659
SHA256 (MesaLib-7.6.1.tar.bz2) = 701f0e4cb85d6298181651b780d1c0a439fadd02aad29ee6623fc05588bb8d44
SIZE (MesaLib-7.6.1.tar.bz2) = 4886995
SHA256 (MesaDemos-7.6.1.tar.bz2) = d2368fc86d032dc6478df70f99b114abdf6c0c1da57bf1d3927ab179876f9c4b
diff --git a/graphics/mesa-demos/files/config b/graphics/mesa-demos/files/config
deleted file mode 100644
index a46afa0e1d7c..000000000000
--- a/graphics/mesa-demos/files/config
+++ /dev/null
@@ -1,30 +0,0 @@
-# Configuration for mesa-demos port for FreeBSD
-# Taken from Mesa CVS mesa/Mesa/configs/freebsd Rev 1.2
-# $FreeBSD$
-#
-
-# Set and remember $CFLAGS, $CXXFLAGS, $CC and $CXX before they are
-# overriden in default include
-
-_CC := $(CC)
-_CXX := $(CXX)
-_CFLAGS := -fPIC -pedantic -I$(LOCALBASE)/include -DUSE_XSHM -DHZ=100 $(CFLAGS) \
- -DPTHREADS $(PTHREAD_CFLAGS)
-_CXXFLAGS := -fPIC -pedantic $(CXXFLAGS)
-
-include $(TOP)/configs/default
-
-CONFIG_NAME = FreeBSD
-
-# Now reset compiler and flags
-CC = $(_CC)
-CXX = $(_CXX)
-CFLAGS = $(_CFLAGS)
-CXXFLAGS = $(_CXXFLAGS)
-
-GLUT_CFLAGS = -fexceptions
-
-LIB_DIR = $(LOCALBASE)/lib
-
-APP_LIB_DEPS = -L$(LIB_DIR) -l$(GLUT_LIB) -l$(GLU_LIB) -l$(GL_LIB) -lXext -lXmu -lXi -lX11 -lm $(PTHREAD_LIBS)
-
diff --git a/graphics/mesa-demos/files/patch-src__mesa__x86-64__glapi_x86-64.S b/graphics/mesa-demos/files/patch-src__mesa__x86-64__glapi_x86-64.S
new file mode 100644
index 000000000000..908a6fe300aa
--- /dev/null
+++ b/graphics/mesa-demos/files/patch-src__mesa__x86-64__glapi_x86-64.S
@@ -0,0 +1,12 @@
+--- ./src/mesa/x86-64/glapi_x86-64.S.orig 2009-03-13 04:28:49.000000000 +0100
++++ ./src/mesa/x86-64/glapi_x86-64.S 2011-01-28 18:12:18.000000000 +0100
+@@ -73,7 +73,8 @@ _x86_64_get_dispatch:
+
+ .p2align 4,,15
+ _x86_64_get_dispatch:
+- movq _gl_DispatchTSD(%rip), %rdi
++ movq _gl_DispatchTSD@GOTPCREL(%rip), %rax
++ movl (%rax), %edi
+ jmp pthread_getspecific@PLT
+
+ #elif defined(THREADS)
diff --git a/graphics/mesa-demos/files/patch-src__mesa__x86-64__xform4.S b/graphics/mesa-demos/files/patch-src__mesa__x86-64__xform4.S
new file mode 100644
index 000000000000..193e6cc30fbe
--- /dev/null
+++ b/graphics/mesa-demos/files/patch-src__mesa__x86-64__xform4.S
@@ -0,0 +1,74 @@
+--- src/mesa/x86-64/xform4.S.orig 2009-01-22 18:38:35.000000000 +0100
++++ src/mesa/x86-64/xform4.S 2011-05-09 21:26:00.000000000 +0200
+@@ -53,7 +53,7 @@ _mesa_x86_64_transform_points4_general:
+ * rdx = source
+ */
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
+@@ -116,7 +116,7 @@ p4_constants:
+ .byte 0x00, 0x00, 0x00, 0x00
+ .byte 0x00, 0x00, 0x00, 0x00
+ .byte 0x00, 0x00, 0x00, 0x00
+-.float 0f+1.0
++.float 1.0
+
+ .text
+ .align 16
+@@ -135,7 +135,7 @@ _mesa_x86_64_transform_points4_3d:
+ movaps 16(%rax), %xmm10
+
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
+@@ -195,7 +195,7 @@ p4_3d_done:
+ _mesa_x86_64_transform_points4_identity:
+
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
+@@ -223,7 +223,7 @@ p4_identity_done:
+ _mesa_3dnow_transform_points4_3d_no_rot:
+
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
+@@ -287,7 +287,7 @@ p4_3d_no_rot_done:
+ _mesa_3dnow_transform_points4_perspective:
+
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
+@@ -353,7 +353,7 @@ p4_perspective_done:
+ _mesa_3dnow_transform_points4_2d_no_rot:
+
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
+@@ -408,7 +408,7 @@ p4_2d_no_rot_done:
+ _mesa_3dnow_transform_points4_2d:
+
+ movl V4F_COUNT(%rdx), %ecx /* count */
+- movzx V4F_STRIDE(%rdx), %eax /* stride */
++ movzbl V4F_STRIDE(%rdx), %eax /* stride */
+
+ movl %ecx, V4F_COUNT(%rdi) /* set dest count */
+ movl $4, V4F_SIZE(%rdi) /* set dest size */
diff --git a/graphics/mesa-demos/files/patch-src__mesa__x86__glapi_x86.S b/graphics/mesa-demos/files/patch-src__mesa__x86__glapi_x86.S
new file mode 100644
index 000000000000..71da78c83ffd
--- /dev/null
+++ b/graphics/mesa-demos/files/patch-src__mesa__x86__glapi_x86.S
@@ -0,0 +1,11 @@
+--- ./src/mesa/x86/glapi_x86.S.orig 2009-03-13 04:28:49.000000000 +0100
++++ ./src/mesa/x86/glapi_x86.S 2011-01-28 18:11:56.000000000 +0100
+@@ -47,7 +47,7 @@
+ #define GL_OFFSET(x) CODEPTR(REGOFF(4 * x, EAX))
+
+ #if defined(GNU_ASSEMBLER) && !defined(__DJGPP__) && !defined(__MINGW32__)
+-#define GLOBL_FN(x) GLOBL x ; .type x, function
++#define GLOBL_FN(x) GLOBL x ; .type x, @function
+ #else
+ #define GLOBL_FN(x) GLOBL x
+ #endif
diff --git a/graphics/mesa-demos/files/patch-src__mesa__x86__read_rgba_span_x86.S b/graphics/mesa-demos/files/patch-src__mesa__x86__read_rgba_span_x86.S
new file mode 100644
index 000000000000..37b08d1cda3c
--- /dev/null
+++ b/graphics/mesa-demos/files/patch-src__mesa__x86__read_rgba_span_x86.S
@@ -0,0 +1,11 @@
+--- ./src/mesa/x86/read_rgba_span_x86.S.orig 2008-08-25 16:46:47.000000000 +0200
++++ ./src/mesa/x86/read_rgba_span_x86.S 2011-01-28 18:10:06.000000000 +0100
+@@ -648,7 +648,7 @@ _generic_read_RGBA_span_RGB565_MMX:
+ testl $0x01, %ecx
+ je .L01
+
+- movzxw (%eax), %ecx
++ movzwl (%eax), %ecx
+ movd %ecx, %mm4
+
+ pshufw $0x00, %mm4, %mm0
diff --git a/graphics/mesa-demos/pkg-plist b/graphics/mesa-demos/pkg-plist
index f72940389afe..e4cbf2e03458 100644
--- a/graphics/mesa-demos/pkg-plist
+++ b/graphics/mesa-demos/pkg-plist
@@ -6,11 +6,11 @@ bin/clearspd
bin/copypix
bin/corender
bin/cubemap
-%%MESALIB76%%bin/dinoshade
+bin/dinoshade
bin/drawpix
bin/engine
bin/fbo_firecube
-%%MESALIB76%%bin/fbotexture
+bin/fbotexture
bin/fire
bin/fogcoord
bin/fplight
@@ -21,11 +21,9 @@ bin/gears
bin/geartrain
bin/glinfo
bin/gloss
-%%MESALIB74%%bin/glslnoise
bin/glsync
bin/gltestperf
bin/glthreads
-%%MESALIB74%%bin/glutfx
bin/glxcontexts
bin/glxdemo
bin/glxgears
@@ -43,14 +41,14 @@ bin/lodbias
bin/manywin
bin/morph3d
bin/multiarb
-%%MESALIB76%%bin/multictx
+bin/multictx
bin/offset
bin/overlay
bin/paltex
bin/pbdemo
bin/pbinfo
bin/pointblast
-%%MESALIB76%%bin/projtex
+bin/projtex
bin/rain
bin/ray
bin/readpix
@@ -58,21 +56,18 @@ bin/reflect
bin/renormal
bin/shadowtex
bin/sharedtex
-%%MESALIB76%%bin/sharedtex_mt
+bin/sharedtex_mt
bin/singlebuffer
bin/spectex
bin/spriteblast
bin/stex3d
-%%MESALIB74%%bin/streaming_rect
bin/teapot
bin/terrain
bin/tessdemo
bin/texcyl
-%%MESALIB74%%bin/texdown
bin/texenv
-%%MESALIB74%%bin/texobj
bin/texture_from_pixmap
-%%MESALIB76%%bin/textures
+bin/textures
bin/trispd
bin/tunnel
bin/tunnel2